0

I was running Elementary OS Loki or Juno (don't remember) on my Asus T100TA laptop. I figured I'd do a clean install of Hera, and since I had nothing of value on my computer I just removed all partitions before proceeding (last resort after hours). I booted into the ISO and started installing (used the first option in the installer, no manual tinkering), but at the end I got the message: "Executing 'grub-install [...]' failed. This is a fatal error." I have tried both running the installer from within the OS, as well as installing it just after the dialog loads at the beginning. I've also connected my computer to the network and chosen to download updates, etc while installing. What do I do now?


No one who can help? I have no idea what to do.

2
  • Create manually / partition, /home partition, /boot partition and swap partition and then try to install it. Swap format as swap, / and /home as ext4 and /boot as fat32 and set boot flag on this partition.
    – Sysadmin
    May 9 '20 at 18:29
  • I have tried; it didn't work. I got the same GRUB error. May 9 '20 at 22:15
0

The solution is to boot to USB and NOT UEFI from boot option menu. Leave the internal hard disks as first bootable options in BIOS, use F-Key (usually F12) at bootup to enter boot option menu.

Then do manual partitioning.

Remove all partitions.

Create primary partition 512 - 1024 MB , format as fat32 and mount as /boot/EFI

Then create swap 8-16GB and format as swap and mount it as a swap.

Create a main partition as primary and here you can choose to format is as LVM, or ext4 and mount as / and give it 50% of your hard drive’s size.

LVM gives you later option to dynamically change the size of each LVM partitions.

Create extended or primary partition , format as LVM or ext4 and mount as /home and give it the second 50% of the hard drive’s size.

The grub boot loader fails during installation because the installation USB is still plugged in and the system is attempting to load the grub to the USB drive. Unplug the USB drive at the point in the installation when asked to install the grub boot loader.

16
  • I am never asked about installing GRUB; That happens automatically (too quickly for me to time with unplugging the usb). Then, how do I do the last part in practice? May 10 '20 at 11:58
  • Remove it earlier when it will start installing packages.
    – Sysadmin
    May 10 '20 at 12:11
  • Doesn't work. It just crashes the installation. May 10 '20 at 12:49
  • Did you create /boot/EFI partition?
    – Sysadmin
    May 10 '20 at 14:56
  • Yes, I created the /boot/EFI partition. Taking the usb stick out crashes the installation, no matter when I do it. May 10 '20 at 15:12
0

You need to install from the UEFI partition on your eOS USB stick. Just choose UEFI USB in the boot options menu when you start your computer.

5
  • There is no such option. The computer only uses UEFI as far as I know. May 9 '20 at 22:14
  • To be sure what your computer chooses, you need to enter the boot options menu by pressing an F-key at start up. It could be F2, F12 or F11 or even the Esc-key.
    – Zonnev
    May 11 '20 at 19:56
  • If you still don't see the UEFI option, you'll need to create your bootable eOS USB differently; with a partition scheme supported for UEFI.
    – Zonnev
    May 11 '20 at 20:21
  • And this link maybe too.
    – Zonnev
    May 11 '20 at 20:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.