0

The activities button, time, icons, everything is gone on my wingpanel. I have tried restarting my computer and killing the wingpanel, but neither of those have helped. I would really appreciate some support, thanks.

  • if you could give some more information I could help you. If wingpanel fails and you want to restart, go to terminal and type: sudo reboot ó sudo poweroff To finish the process you can also do it from the terminal using: 1. htop 2. What process is causing you problems (try an app that is using more resources than usual) 3. To kill the process select and with F9, you finish it. But as I told you if you have more information than you did before, be it, customize wingpanel or something else, say it to know more clearly what to do. Best of luck, regards. – black bird May 5 at 20:39
  • as far as I saw in reddit you have installed ayatana indicator applet, I recommend you to add this into your question, also everything you have made before the probem occures. – Bo rislav May 6 at 19:41
  • wasn't that project laid on ice a couple of years ago? No wonder if it give people trouble. – Storm May 8 at 15:59
0

I recomend you to try to reinstall it, using sudo apt install --reinstall wingpanel.

| improve this answer | |
0

I have been having the same issues for the past 1 month, never faced it before in my roughly 2 years of using eOS as my primary OS.

Running "wingpanel" in terminal seems to bring it back, but it's an active process in the terminal, so if I close terminal, I lose the wingpanel again.

Also the wingpanel only disappears when I click on the sound icon, the wifi, bluetooth,date, applications button all work fine.

Tried uninstalling and reinstalling it, didn't work. Let me know if something works for you.

Edit 1: Now I am unable to login to eOS. Get the following error code "elementary os session returned error code 1". Welp... :(

Edit 2: I solved the wingpanel issue by reinstalling the default music player. :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.