0

I am using eos hera 5.1 When I try to install Files from appcenter it fails with a response I tried installing some other apps and they work fine

The package id's '' are not valid

Screenshot of the error

  • Sounds similar to this issue: github.com/elementary/appcenter/issues/460. Have you tried running sudo apt update and sudo apt upgrade in a terminal and then restarting? – Jeremy Wootten May 5 at 6:41
  • Tried that already and didn't work. Still the same – Shahi C May 5 at 7:20
  • Try running appstreamcli dump io.elementary.files | grep pkgname in a terminal. It should find a <pkgname>pantheon-files<\pkgname> tag. If this is missing or empty it would give rise to your error. It is OK for me on both a stable and daily install of elementary Hera. – Jeremy Wootten May 6 at 18:03
  • tried it and got the reponse <pkgname>pantheon-files</pkgname>. Its not missing but the issue still persists – Shahi C May 13 at 0:06
  • Can you run pkcon resolve pantheon-files and post the output? – David Hewitt May 14 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.