I want to dual boot Windows 10 and Elementary OS 5.1.3 on my Dell Inspiron 13 7391 2 in 1. I was able to run and seemingly complete the installation process from USB, however, when I attempt to run the installation entry ubuntu from my system's boot menu, I get a loud beep and my system begins running hardware memory diagnostics. This does not happen when booting Windows 10. I was unable to find any ubuntu folder created in my EFI partition when I browsed it using my BIOS.

I have heard that this may possibly be a problem with compatibility with Intel RAID hard drive technology (instead of AHCI). (Note: BitLocker came enabled by default on my hard drive.) However, when I attempted to switch my system to AHCI mode, it triggered an automatic repair when booting Windows 10.

Any advice in terms of getting Windows 10 and Elementary OS to boot successfully together? Or is Elementary OS simply not compatible with my hardware? Thanks in advance.

Edit: A reinstall with 5.1.4 allowed me to boot into a Grub menu that could not read any partitions on my hard drive other than EFI. Booting the Elementary OS live CD and running boot-repair returned my system to the state where it beeps and starts running diagnostics when attempting to boot the ubuntu boot entry. While in the Elementary OS live CD, I noticed that gparted correctly recognized the install partition, but Windows still sees it as allocated space. When attempting to mount the EFI partition in Windows, Powershell reports that the files in the ubuntu directory are unreadable.

1 Answer 1


Update: I ultimately ended up installing Ubuntu, but I believe the steps I used to fix the problem would also work for elementary OS. Be sure to back up your data for the unlikely event that something goes wrong while doing these steps.

It's been a while since I've completed the steps, so follow these instructions at your own risk.

First, I used the "Intel Optane Memory and Storage Management" application to disable Intel Optane Memory system acceleration and reboot. (Forgetting this step will cause Windows to enter "automatic repair" mode on boot in AHCI mode.)

Then, launch msconfig and enable minimal Safe Mode on the boot tab.

Then boot into the BIOS configuration and set the SATA hard disk operation mode to AHCI mode.

Reboot (into safe mode), and then launch msconfig again, and disable Safe Mode on the boot tab.

Reboot one last time. Your Windows system should function as normal. At this point you can resume the normal process of installing elementary OS/Ubuntu, including resizing partitions, etc.

Note 1: I personally have not noticed a reduction in Windows speed from disabling the memory acceleration and switching the SATA operation mode from RAID to AHCI.

Note 2: If Windows has a problem booting, try temporarily switching the SATA operation mode back to RAID.

(Reference for switching Windows to AHCI mode: https://superuser.com/a/1359471).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.