1

When using Elementary (5.1.3) to stream music or video it goes to sleep after a while. I don't really want to change the power settings but would like Elementary to recognise when a stream is active and allow it to continue. Other posts suggest solutions such as caffiene no longer work. Is there a way to get the behaviour I would like please? With thanks in advance!

Steve

3

This issue is more on lightdm, I've already explained this before so I won't explain further and rather I'll just put steps here, This problem is because the power settings are used from the gconf configuration of the user lightdm, and not the current user. Just test:

sudo su
su - -s /bin/bash lightdm
gsettings get org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type

If these returns suspend then you can pass nothing like below to change it and you should be good.

dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type nothing

just ignore any output you get, reboot to take in effect, In my experience OS update 3 weeks ago reverted this setting which was in place since last year, but same worked again.

Also just verify power settings after reboot. incase you still having issues.

  • Thank you very much Raj, for taking the time to post this answer. It does seem to have resolved this issue for me. Thank you again! – Steve Brodie May 1 '20 at 6:41
  • Oh dear, I spoke too soon! My audio stream stopped just a few minutes after posting the previous comment! :( – Steve Brodie May 1 '20 at 6:48
  • 1
    The first code returns suspend even after running the second command and rebooting. – Steve Brodie May 1 '20 at 7:02
  • 1
    Have run this again and audio does seem to continue now. Thank you! Fingers crossed it is resolved! – Steve Brodie May 1 '20 at 8:53
  • 1
    I have found I have to reboot using systemctl reboot -i' i don't know if that has any relevance on whether this works or not? – Steve Brodie May 1 '20 at 20:51
0

What about something like keep awake

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.