Under System Settings > Applications I have Photo Viewer set as the default image viewer. However, when I click on an image using Files, it opens with Image Resizer. I need to right click to open an image with Photo Viewer.

screenshot of application default settings

1 Answer 1


In order to fix this, right mouse click on an image file, select Open with and choose from the menu there Other application, no matter that your favorite application is on the list above. On the next popup screen choose your fav application and set the checkbox Set as default if it isn't set already and confirm with Select.

note: If your favorite application is not in the list, probably you can find it using the "View All Applications button" there.

From now on, all files with this file extension will be open with the application you just choosed for. Image files can be a lot of different file extension formats and the settings you describe using the screenshot on your question cannot fit for all of them (installing a new program can steal the right for automatic open of some, for example), so this is the way you can change the default program for any file extension(not only images), following the steps above. Again, the steps I have described will not work for all image files automatically, but for all files with the current extension you've set up. If you want to change it for another ones also, you have to repeat the steps above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.