0

After switching to default russian, I'm stuck with ru language as start language, and no way to change it. None of regular language switching keys working( No alt+enter, shift+alt, or caps lock (which I had previously as a default for layout switching).

Since, obviously my password is in English, I'm stuck at the loading screen. Switching to the recovery doesn't help ether since there is no way to enter commands in russian. What should I do now? I'm already considering wiping clean whole disk, but that is not something I want to do, since I have some work done which I prefer to have saved.

1

There are two ways you can change the language setting:

  1. change Keyboard Which you can change by Alt+Shift
  2. change input method Which you can change by Alt+Space(By default disabled)

Option one is easy even you can change at login-screen, But if you changed input-method this you can't change at login-screen using Alt+Space because ibus is not running by default, to fix that issue just press Ctrl+Alt+F1 or F2 login using your credentials and install below:

sudo apt install ibus-m17n

Then reboot and you should be able to change input-method at login screen using Alt+Space

| improve this answer | |
  • That would've worked if my credentials were in Ru. But they are not. So, no matter if I enter them inside of a regular terminal or on a login screen - the input is in russian, and I simply can't login. Both ways that you've provided for switching the layout doesn't work, that's the point, and I've written about it in my question! – Igor Apr 30 at 10:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.