0

A couple Days ago my fresh eOS install stopped reacting at all when pressing power-off or reboot.

Shutting down works when not logged in or being logged into the guest account. I cannot figure out why that is, I suppose it has something to do with the removal of xscreensaver but im not sure.

Can someone please assist me in that case?

What I already did:

  • editing grub to acpi=force
  • changing the poweroff delay force from 90seconds to 6 seconds

None of that helped.

I have suspected installs:

  • timeshift for backups
  • kde-connect
  • additional taskbar that shows minimized programs
  • wingpanel-indicator-ayatana
  • xscreensaver (removed)
  • caffeine (removed)

How do I log the shutdown sequence? That would help a lot.

Ordering shutdown -h in terminal works but that is no long-time option.


EDIT: sudo wingpanel after the problem occurred, reenables the shutdown option. Locking results in Error message:

(wingpanel:4084): wingpanel-WARNING **: 15:20:26.624: SessionManager.vala:60: Error registering client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(wingpanel:4084): wingpanel-WARNING **: 15:20:26.624: Wingpanel.vala:53: Failed to register with Session manager

** (wingpanel:4084): WARNING **: 15:20:56.026: Indicator.vala:163: Unable to lock: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: \n The name org.freedesktop.ScreenSaver was not provided by any .service files

** (wingpanel:4084): CRITICAL **: 15:20:40.286: DisplayWidget.vala:159: Unknown network state, cannot show the good icon: NETWORK_STATE_FAILED_WIRED

** (wingpanel:4084): CRITICAL **: 15:20:54.846: session_widgets_userbox_update_state: assertion 'self != NULL' failed


EDIT2:

reinstalling wingpanel from pantheon updated the error messages:

When trying to Suspend or Shutdown:

Unable to shutdown: GDBus.Error:System.Error.ESTALE: Stale file handle Indicator.vala:151: Unable to suspend: GDBus.Error:System.Error.ESTALE: Stale file handle

i just opened a bug report at github: https://github.com/elementary/wingpanel/issues/320

1

I have the same problem. sudo wingpanel fixes this for the moment. I always put the pc into standby and most of the time, there are two user sessions. I just did some tests and could reproduce and "fix" it:

  • start E OS
  • login with user A
  • at the power Menu choose user B
  • login with user B
  • at the power Menu choose user A
  • login with User A
  • at the power Menu try to choose User B (you can't choose it anymore)
  • at the power Menu, choose standby Nothing happens an in the journal, there comes the stale file handle message

  • logout user A

  • at the login screen, standby or reboot also will not work
  • enter Password for logged in User B
  • at the power menu, choose standby PC will go into standby

this is a very strange behaviour and i also don't have an idea, whats happening.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.