0

for those who are desperate of mounting their ntfs drives read and write , and dual booting aside win 10 , Read this : I know that this may sound simple and weired , but I installed elemntary OS as a second os beside win 10 , and I tried to mount ntfs multiple drives ,I followed these steps :

  1. I mounted them manually one by one each startup , I found it too boring for me to do every time , and they also were read only .
  2. I came up with the idea to edit /etc/fstab by getting UUID through blkid command and adding drives one by one to this file and adding mounting points , with adding rw in the options , it didn't work.
  3. I switched to windows 10 , turned off quick startup ,unchecked drive caching in device manager, and pressed shift while shutting down to shutdown windows completely and prevent hibernation , rebooted to eOS , IT DIDN'T WORK EITHER .
  4. I tried chown , chmod , changing mount points , umask=000 , user before rw in fstab options and vice versa , none of this worked for me .
  5. The solution was to install ntfs-3g using sudo apt-get install ntfs-3g ,and It even worked for me using only defaults in options , I didn't write rw , I used a random mount point , I even didn't change drive type from ntfs to ntfs-3g , and drives are mounted each startup automatically with read and write permissions .

I just want to leave an extra solution ,you can talk to me for further investigation if want , this is my first time to submit a contribution in a stack exchange community so I'm sorry for this mess, Thanks .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.