0

Is there any driver for Thinkpad T480s fingerprint reader? I have already tried Figerprint GUI and fprint-demo but without succes.

2
  • have you had any luck with this? Same problem here. Found this guide, which I followed, but reader is still not found with Fingerprint GUI: launchpad.net/~3v1n0/+archive/ubuntu/libfprint-vfs0090 Jul 19 '20 at 0:39
  • I didn't manage to install it. ❯ sudo validity-sensors-tools.led-test Unable to access to USB devices validity-sensors-tools is installed as a snap. To allow it to function correctly you may need to run: sudo snap connect validity-sensors-tools:raw-usb sudo snap connect validity-sensors-tools:hardware-observe Jul 23 '20 at 11:11
0

The fingerprint reader for the T480s will work in eOS6, as it has a newer kernel that supports it. You may need to install the Python Validity interface, though.

If you're running eOS6 (or have a kernel that is 5.4.x or newer), try this:

  1. Open Terminal (if it's not already open)
  2. List your USB devices:
    sudo lsusb 
    
  3. Look for the fingerprint reader, which may look something like:
    Bus 001 Device 005: ID 06cb:009a Synaptics, Inc. Metallica MIS Touch Fingerprint Reader
    
  4. If you already have the basic PAM Validity driver installed, try to enrol a finger:
    fprintd-enroll
    
    If this comes back with an error, install the Python Validity drivers:
    sudo apt remove fprintd
    sudo add-apt-repository ppa:uunicorn/open-fprintd
    sudo apt update
    sudo apt install open-fprintd fprintd-clients python3-validity
    
    Once everything has finished installing, try to enrol a finger:
    fprintd-enroll
    

This has been successfully configured on four Lenovo ThinkPad T480s notebooks (Japanese model) running Elementary OS 6 👍🏻

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.