2

My PC -

Processor: Intel(R) Core(TM) i5-6600K CPU @ 3.50GHz (4 CPUs), ~3.5GHz Memory: 16384MB RAM Video Card name: Radeon RX 580 Series

Downloaded elementaryos-5.1-stable.20200405.iso and Rufus 3.9

Followed instructions to the letter, including the checksum hash.

When booting from the USB, all I get is a blank screen. No error messages.

Any ideas?

  • Is the computer locked up hard? Can you get to a virtual console by pressing Ctrl+Alt+F1? – feoh Apr 17 at 17:34
  • Yes it was, but I discovered two boot entries for the USB drive I was using - one was named UEFI, the other not. I had been using the UEFI version, so I tried changing it to the plain USB stick name, and it worked. No idea why that should be! – Kiwijetpilot Apr 17 at 21:32
  • Secure Boot is a complete and utter pain in the butt. I have to disable it on my Surface Pro 3 and instead of booting cleanly it boots with a bright red screen (supposedly to show you are not in Secure Boot mode). I'd be interested to hear if anyone has had any success getting Elemenraty running on a Surface Pro 3. – Jon Biddell May 9 at 7:42
  • All you have to do is to leave primary disk in BIOS. Just press F12 then choose usb stick boot from it and never use Rufus. Use Balena Etcher to prepare Elementary OS usb stick with iso file. Then it should go. If you prefer manual partitioning, then you must create a primary partition, format it as fat32 , mount it as /boot/EFI and set the boot flag on this partition. – Sysadmin May 10 at 4:21
0

This sounds like Secure Boot is active. You should be able to use UEFI with elementary os, but Secure Boot can be a challange. Try turning it off in BIOS and boot again from UEFI USB.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.