3

I am trying to install LibreOffice 5.0 on Freya 64 bit. This is a fresh install and does not have any previous versions of LibreOffice. When I apply the LibreOffice fresh official PPA, I get an error saying that python3-uno will not be installed. This is the exact error message:

The following packages have unmet dependencies: libreoffice : Depends: python3-uno (>= 4.4.0~beta2) but it is not going to be installed.

I have checked that my system does not have any version of python3-uno installed. And also the PPA does not provide its own version. Since I am coming from Arch Linux, I am not used to frozen software. I really like the elementary user interface. Any help on installing the latest version LibreOffice will be appreciated.

3

Solved it. It was actually very simple and my fault. Coming from arch, i don't know how ubuntu based systems are supposed to work. I just installed the repository version of libreoffice and then added the ppa. The upgrade was flawless and I am running libreoffice 5.

2

Open terminal and run the following commands:

To install LibreOffice 5 :

sudo add-apt-repository ppa:libreoffice/libreoffice-5-0
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install libreoffice

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.