The AppCenter has problems updating. This type of error appears multiple times here, but I think they're all a bit different?

I get the following notice:

W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://download.opensuse.org/repositories/network:/messaging:/xmpp:/dino/xUbuntu_18.04  InRelease: The following signatures were invalid: EXPKEYSIG 62EB1A0917280DDF network OBS Project <network@build.opensuse.org>
E: http://download.opensuse.org/repositories/network:/messaging:/xmpp:/dino/xUbuntu_18.04  InRelease is not (yet) available (The following signatures were invalid: EXPKEYSIG 62EB1A0917280DDF network OBS Project

This seems more specific than the other questions. Can anybody tell me what went wrong (and how to fix it)?

2 Answers 2


Solved this by following the steps on https://software.opensuse.org/download.html?project=network:messaging:xmpp:dino&package=dino

sudo sh -c "echo 'deb http://download.opensuse.org/repositories/network:/messaging:/xmpp:/dino/xUbuntu_18.04/ /' > /etc/apt/sources.list.d/network:messaging:xmpp:dino.list"
wget -nv https://download.opensuse.org/repositories/network:messaging:xmpp:dino/xUbuntu_18.04/Release.key -O Release.key
sudo apt-key add - < Release.key
sudo apt-get update

Not sure why this failed though? Was the key renewed? How can I (a user) tell?


That is the OpenSuse PPA, not elementary os. Looks like you added that one for installing OBS. As flatpack support is added, I would go with that, to remove modifications to the system and keep it stable.

  • how can I tell what the modifications are?
    – Friso
    Apr 23, 2020 at 14:39
  • Actually I probably did this for dino.im for which I don't think there is flatpak support (github.com/dino/dino/pull/343)
    – Friso
    Apr 23, 2020 at 15:24
  • @Friso You can find them in /etc/apt/sources.list or as a separate file in /etc/apt/sources.list It is mostly a line like: deb http://download.opensuse.org/repositories/network:/messaging:/xmpp:/dino/xUbuntu_18.04 bionic main or similar. But I saw you already solved this? Great to see. May 18, 2020 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.