0

So, I've figured that I can set up any shortcut to open my terminal and currently I use cmd+enter to start it, it is very convenient and helps greatly when I need quick access to terminal. BUT when I need to open up another terminal with the same shortcut -> I can't do so. So, I have to go to the recently opened terminal (which could be located on 2nd or 3rd screen for example), and hit ctrl+shift+n to open up another one. Takes time. Inconvenient. Any setting I can input to override default "One and Only one terminal at one hands" policy?

  • Added a tutorial about terminal and tmux. What you need is to press Ctrl+Shift+n when you have opened terminal and it will open new window. Nobody provided this simplest solution. Probably, because they do not work much with terminal every day as sysadmin. :) – Sysadmin Jul 4 at 11:54
  • Please, read my question first. I already know about ctrl + shift + n shortcut. – Igor Jul 8 at 13:48
0

I've tried to replicate what you are saying and yes, I can't open another terminal window through the key shortcut if the terminal is already open.

Anyway, instead of looking for the open terminal window among the screens, both physical or virtual you have, to save some time and make this thing less complex, you could just right click on the terminal icon in plank and select new window. Plank appears in every virtual desktop you create

Let me know if this helps

| improve this answer | |
  • 1
    Clicking on something requires additional time to grab a mouse and pointing it to a specific zone on a screen, which is usually even slower than moving through a virtual screens on a keyboard, so I guess that is not something usable in my case. – Igor Apr 16 at 6:11
0

Why not create a bash script or use xbindkeys to execute a command that will always open a new terminal window for you on the hotkey you are wanting to use? Seems like it'd be simple to do.

| improve this answer | |
0

I was having the same problem a couple of days ago.

Couldn't figure out anything so in the end I replaced the default terminal with the gnome terminal.

What I did was:

  1. Install gnome terminal
  2. open dconf
  3. change /org/gnome/desktop/applications/terminal/exec from io.elementary.terminal to gnome-terminal
  4. change exec-arg to ''
| improve this answer | |
0

well ... if you add the terminal app to the tray at the bottom ... if you right click it ... it will give you an option to open a new terminal window

| improve this answer | |
0

tmux tmux-servers tmux-bashtop

Images show how tmux works.

When you have opened the terminal with the combination:

Ctrl+Alt+t which works by default just press:

Ctrl+Shift+n combination and it will open new terminal window each time when you will press it.

Ctrl+Shift+t combination opens new tab.

Alt+1/2/3/4/5/6/7/8/9 (Page Up) switches between tabs.

Ctrl+Shift+w combination closes the current/active tab.

Ctrl+d combination = exit or logout. It closes the tab.

Ctrl+l combination = clear (current window).

Alt+F4 combination closes the terminal.

There is no need to create another shortcut. Then just click on the + symbol on the window bar, top left corner and it will open one more tab. Simple as that. If you want to divide one window terminal instead of opening one by one install tmux and learn how to use it. Much more convenient than tabs. I prefer it than multitabs.

sudo apt install tmux

Press Ctrl+b and then type % and it will divide window vertically

Press Ctrl+b and then type " and it will divide window horizontally

Press Ctrl+b and then type o to switch between panels in tmux.

Press ctrl+d or type exit, to close the panel in tmux.

I am using htop, glances, bashtop, cmatrix and cava on the screenshots and standard Elementary OS terminal.

| improve this answer | |
  • The tmux look nice, but my question was about the original terminal, I would prefer the Elementary developers to fix it, or find some workaround, since I am get used to start a terminal with just one and only one shortcut as it works on Ubuntu for example. – Igor Jul 7 at 7:04
  • Did you read all what I wrote? It seems not. Shortcuts already works in default Elementary OS I am using and provided them. The post is not only about tmux. Hah. As always TL; DR; Read carefully once again. Open terminal and use shortcuts I provided. Especially Shift+Ctrl+n ;) – Sysadmin Jul 7 at 14:55
  • I've read it. But the question you was giving answer to was "Which shortcuts to use to do this or that", mine question is a bit different. I want to configure ONE and only one shortcut, to open 2 terminals on the same work table. It perfectly works on Ubuntu, but it doesn't work in Elementary. Why should I memorize all these keystrokes at all? I want convenience - hit two buttons -> get first terminal -> hit same two buttons -> get another one. Not hit this, then hit that, then hit something else, and keep track of what you hit or not already or you doomed. – Igor Jul 8 at 13:47
  • Ech... Open terminal with Shift+Ctrl+t, then in opened terminal press Shift+Ctrl+n to open new terminal window simple as that. Nothing special and not very difficult to memorize. Especially when Shift+Ctrl+n works almost everywhere. The same with Shift+Ctrl+t which opens new tab. Learning these shortcuts is something what children is able to remember. You can of course change the shortcut in Elementary OS settings to open terminal with different shortcut like I did and open it with Windows logo on keyboard (super key)+t. – Sysadmin Jul 8 at 14:12
  • You can of course change the shortcut in Elementary OS settings to open terminal with different shortcut like I did and open it with Windows logo on keyboard (super key)+t. And now we are at the start of my question. The shortcut doesn't work as desired) Try opening another terminal with it on Elementary OS. – Igor Jul 8 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.