0

I'm trying to swap "change keyboard layout" shortcut with "application menu" shortcut; it became universal that changing language is "super+space" and i've used KDE a lot and i got used to "alt+space" to launch something similar to highlight in MAC OS.

I've managed to edit "super+space" and make it "alt+space" using dconf-tool.

But when i failed to edit "alt+shift" to make it "super+space".

I found two ways, the first is deprecated from freya which is found in org.pantheon.desktop.gala.keybindings.switch-input-source

and the second is in

org.gnome.desktop.input-sources

I tried to

  1. make the value of "xkb-options" = ['grp:super_shiftspace_toggle']

  2. edit /usr/share/X11/xkb/rules and set any file containing grp:alt_shift_toggle Alt+Shift into grp:super_space_toggle Super+Space

  3. repeated number 2 but just adding not replacing the value

The only reason i want to change "alt+shift" is that it interferes/prevents any combination of keys that has alt+shift inside of it (for example in intellij ctrl+alt+shift+s it skips shift, and 100% the reason is the alt+shift keyboard layout shortcut because when i changed/disabled it nothing caused this issue)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.