1

For many years, performing a middle click on a dock item (e.g. Terminal, Files), will open a new instance of the application e.g. if you want two terminal windows open to view side by side.

Recently, this is no longer working and a pinwheel spins for a while and then no action occurs. The only workaround so far is to right click on the icon and choose "New Window"

How can I restore this necessary functionality?

  • This is likely an issue with the specific apps (e.g. Terminal, Files) rather than the dock as I can't see any significant changes there that would the cause of this. It may be worth opening an issue on the relevant GitHub pages. – David Hewitt Jun 9 at 12:04
  • Middle mouse click works for me, but I compiled Plank from the source. – Storm Jun 9 at 12:06
  • Which application exhibit this behaviour? I tried Firefox and a new window shows up. Terminal and Files instead are just focused and no new window is created. So as suggested by @DavidHewitt it seems an application related issue. – endorama Jun 9 at 14:00
  • 1
    terminal and files in particular ones i've noticed. these applications are supplied by elementary, suggesting a common config/issue, and only recently started exhibiting this behaviour in recent months – Simon B Jun 9 at 14:20
-1
cd && cd Downloads
wget https://launchpad.net/ubuntu/+archive/primary/+sourcefiles/plank/0.11.89-1/plank_0.11.89.orig.tar.xz
tar xf plank_0.11.89.orig.tar.xz
cd plank-0.11.89
 ./configure
make
sudo make install
sudo apt install --reinstall plank libplank*

Additionally to enable zoom in Plank:

Two files need to be edited before you can get the zoom effect, copy/paste.

sudo nano /usr/local/share/plank/themes/Default/dock.theme

Add the following in the end of the file;

ZoomEnabled=true
ZoomPercent=150

Save: [ctrl]+[o] and Exit: [ctrl]+[x]

The last file to edit is the schema file of Plank.

sudo nano /usr/share/glib-2.0/schemas/net.launchpad.plank.gschema.xml

Look for (near the end of the file).

false

Change false to true

Save: [ctrl]+[o] and Exit: [ctrl]+[x]

Last thing.

killall plank&& plank&
plank --preferences

Now enable Zoom effect in preferences.

| improve this answer | |
  • this answer doesn't appear to have anything to do with the question – Simon B Jun 16 at 11:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.