Running elementary OS freya 0.3.1 Freya with network printer HP Photosmart 7520 All-In-One Inkjet Printer/Copier/Scanner/Fax.

Printer works fine.

When I invoke Simple Scan to scan a document, the following error is displayed:

No scanners detected

Please check your scanner is connected and powered on

  • Have you installed any additional drivers for it?
    – r3bl
    Oct 9 '15 at 12:56
  • @r3bl It's shouldn't be necessary. According to the HPLIP-Database HP Photosmart 7520 should be fully supported since version 3.12.9. elementary OS provides version 3.14.3
    – Rafael
    Oct 10 '15 at 8:17
  • Please check if libsane-hpaio is installed. You can do it with running the following command in your terminal: dpkg -l | grep libsane-hpaio. If it's not installed, install it with sudo apt-get install libsane-hpaio.
    – Rafael
    Oct 10 '15 at 8:26
  • @Rafael Output of dpkg -l command indicates libsane-hpaio is installed.
    – Donald
    Oct 20 '15 at 2:51
  • I have the same problem with HP ENVY 4502 this very same printer scans and prints fine with other distros (ubuntu,linux lite,mint) on a network connection,only elementary fails to recognize scannner. This is what I get on terminal when I tried to reinstall hplip: Reading package lists... Done Building dependency tree Reading state information... Done libsane-hpaio is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    – Ari Torres
    Mar 5 '16 at 11:29

If I do a direct connection to my HP Officejet Pro L7590 via USB, the printer is immediately recognized as a scanner as well. So, contrary to HP's own documentation, this seems to be a limitation of libsane-hpaio when trying to use over a wired network. This is the only way I have managed to get this to work.


Remove printer from system settings.


hp-setup -u
  • You haven't explained what the command does or what the flag does.
    – RolandiXor
    Dec 9 '15 at 13:16

I had a similar problem with my hp deskjet 2540 which I solved the following way:

  1. Make sure you have the hplip installed
  2. open system-config-printer from the command line
  3. Add the printer again (I called it "Scanner") and make sure you use the HP JetDirect Connection not IPP

Afterwards, I was able to scan even over wifi. Same trick worked on a Mint machine as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.