0

Sorry to bring this up after ~3 years, but I'm stuck on the suggested solution:

I have a similar issue, but when I'm running this:

sudo apt install switchboard-plug-gcc-sound

I get this:

The following packages have unmet dependencies:
 switchboard-plug-gcc-sound : Depends: unity-control-center but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The above iterates for all the "unmet dependencies".

Any clue about what I might be missing here, would be much appreciated!

Thank you in advance!

  • Try running sudo dpkg –configure -a If you have Synaptic Packaage Manager, you can also use that to fix broken packages. – Paul Apr 8 at 2:35
  • Thank you for your time. I still get the same message: The following packages have unmet dependencies: switchboard-plug-gcc-sound : Depends: unity-control-center but it is not going to be installed E: Unable to correct problems, you have held broken packages. – Lopofsky Apr 9 at 15:13
0

I have also faced the same issue. I managed to get the packages installed by using aptitude instead of apt-get or apt.

aptitude also detects the dependency issues, but offers a few more automated solutions. The second solution it offered was to remove libglib2.0-bin, install libglib2.0-bin:i386, and upgrade libglib2.0-0, libglib2.0-0:i386, and libglib2.0-dev. This worked and I got my sound settings back.

However there may be consequences I'm not aware of, so please exercise caution.

| improve this answer | |
  • I'll check it asap and mark it as solved if your suggestion works, thank you for this insight. – Lopofsky Apr 26 at 13:08
  • My god thank you so much! This fixed it! At the cmd I've refused the 1st solution (mostly summed up to "leave things as they were") & accepted the 2nd one and it worked! – Lopofsky Apr 29 at 16:36
0

After the update, I had exactly the same problem.

These packages are removed: ibus ibus-table switchboard-plug-gcc-color switchboard-plug-gcc-sound switchboard-plug-gcc-wacom unity-control-center

These packages have been updated: ibus-gtk (1.5.11-1ubuntu2.3) to 1.5.11-1ubuntu2.4 ibus-gtk3 (1.5.11-1ubuntu2.3) to 1.5.11-1ubuntu2.4 libibus-1.0-5 (1.5.11-1ubuntu2.3) to 1.5.11-1ubuntu2.4

| improve this answer | |
  • @Lopofsky 1) delete gir1.2-ibus-1.0_1.5.11-1ubuntu2.4_amd64 2) download and install gir1.2-ibus-1.0_1.5.11-1ubuntu2_amd64 3) download and install ibus_1.5.11-1ubuntu2_amd64 4) download and install ibus-table_1.9.21-2_all.deb 5) install from the repository switchboard-plug-gcc-sound 6) PROFIT – m-matveev Apr 9 at 15:09
  • Thank you for the insights! So where can i find the repos for the steps 2 & 3? I mean through apt list --installed | grep fir1.2-ibus, I do find that you are correct about step 1, but the "apt-cache search ibus | grep "^ibus-1.5.*"" doesn't return any results for step 3 | "apt-cache search ibus | grep "^ibus-table_1.*" the same for step 4 and so on. – Lopofsky Apr 9 at 15:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.