0

Reposting this article from Lenovo Forums to seek help from eOS community.

Issue

I get a black screen after I wake my laptop from suspension. So I have to forcefully shut down using the power button and as a result I lose all opened webpages and documents.

From lights on keys like numlock/capslock, I can say that the keyboard is working in this state. I also hear the sound of the laptop's fan. So apparently the OS does load but doesn't show anything on the screen. The issue occurs mostly, but not always.

Laptop specs

Laptop: Thinkpad E585
Graphics Card: AMD Radeon RX Vega 10
OS: elementary OS 5.1.2. Earlier I tried Ubuntu 18.04.3.
Kernel: 5.5.9-050509-generic
BIOS: 1.56
Dual-boot with Windows 10.

Unsuccessful attempts

  1. I have tried several versions of Linux kernel:
    (a) 4.19.79 instructed here
    (b) 4.19.91
    (c) 5.0.0.37 which was preinstalled with elementary OS,
    (d) 5.3.12 as advised here
    (e) 5.4.6 as instructed here
    (f) 5.4.12
    (g) 5.5.3

  2. Also, I have upgraded BIOS two times in the last year when Lenovo released them. I remember once from 1.38 to 1.50 and then from 1.50 to 1.56.

  3. I also tried All Open and Pro variants of amdgpu drivers provided by AMD here.

  4. (a) In the /etc/default/grub file, I set: GRUB_CMDLINE_LINUX="amd_iommu=pt ivrs_ioapic[32]=00:14.0 iommu=soft trace_clock=global" as instructed here.

    (b) I tried:GRUB_CMDLINE_LINUX_DEFAULT="quiet splash ivrs_ioapic[32]=00:14.0 spec_store_bypass_disable=prctl which I had also done when I had installed Linux for the first time as mentioned here.

    (c) I also tried:GRUB_CMDLINE_LINUX="nouveau.modeset=0 as advised here.

  5. The issue is there for both secure mode on and off.

  6. I created a 14 GB SWAP file as mentioned here to supplement an already created 20 GB SWAP partition. My RAM is 16 GB and now in total my SWAP area sums to roughly 34 GB.

  7. Lenovo Technical Support said they only make hardware and I should contact Microsoft for software support. They do not seem to care about Linux users.

At the moment, nothing seems to work. Any help would be greatly appreciated!

Log file

If it helps, here is the log file I generated with journalctl -o short-precise -k -b -1 as mentioned here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.