6

I have a USB audio device that has input and output from/to guitar. It gets power from USB. It was working all well before. But after recent updates, It's kind of half-working. The device only gets power when there is some audio is being playing in laptop or some input signal is sent from guitar. So, If I stop playing guitar for a second, it turns off and when I play again it goes on. I want to get continuous power. Is there any way I can fix this problem?

2
+50

This question seems really simular: https://superuser.com/questions/408683/why-my-usb-mouse-gets-suspended-after-3-seconds-of-inactivity

You can check if you have the same issue as the one above by entering the command:

for i in /sys/bus/usb/devices/*/power/control; do echo on > $i; done

If this fixes your problem, you can make it permanent by editing /etc/laptop-mode/conf.d/usb-autosuspend.conf in scratch

sudo scratch-text-editor /etc/laptop-mode/conf.d/usb-autosuspend.conf

and replacing CONTROL_USB_AUTOSUSPEND="auto" by CONTROL_USB_AUTOSUSPEND=0

[Edit]

The permanent fix seems to have changed, if modprobe usbcore autosuspend=-1 doesn't do anything, you need to change the bootloader. To do this, you have to open the GRUB config in scratch. sudo scratch-text-editor /etc/default/grub and loof for a line that states GRUB_CMDLINE_LINUX_DEFAULT and add usbcore.autosuspend=-1 to that line.

The line will be something along the lines of this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbcore.autosuspend=-1"

  • This command above with the for loop enabled power for my guitar. But I could not locate usb-audosuspend.conf file, because path doesn't exist. I have put that first command in a file, and run it when I need to use that device. Permanent fix would be awesome. – dg_no_9 Oct 14 '15 at 14:17
  • It might be in one of these files: /etc/modprobe.conf, /etc/modprobe.d/modprobe.conf or /etc/modprobe.d/options. Look for options usbcore autosuspend=1 – Jeroen Oct 14 '15 at 14:39
  • I have only /etc/modprobe.d/modesetting.conf file which has options in int. But there is no options for usbcore. Should I add options usbcore to this file or create a new file? – dg_no_9 Oct 14 '15 at 15:45
  • No you should not have to create those files. Does the command modprobe usbcore autosuspend=-1 return anything? – Jeroen Oct 14 '15 at 17:04
  • 1
    @dg_no_9 No problem, I'm just a bit bussy today (deadlines ugh...) so I don't really have time right now. Will help you tomorrow :) – Jeroen Oct 15 '15 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.