1

I would install wine. but by installing dependency packages, my Touchpad driver uninstalled automatically. so I try install it (Driver) again. but after reboot, system wasn't boot and stuck at black screen. If you think this is not bug, please just tell me how can I install Wine, without disabling ALPS-Touch-pad driver?

for more details, you can see this logs.

hamed@Hamed-PC:~$ sudo apt-get install wine 
[sudo] password for hamed: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 wine : Depends: wine1.6 but it is not going to be installed
 E: Unable to correct problems, you have held broken packages.

hamed@Hamed-PC:~$ sudo apt-get install wine1.6 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
   wine1.6 : Depends: wine1.6-i386 (= 1:1.6.2-0ubuntu4)
            Recommends: winbind but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

hamed@Hamed-PC:~$ sudo apt-get install  wine1.6-i386 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
    wine1.6-i386:i386 : Depends: libglu1-mesa:i386 but it is not going to be installed or
                          libglu1:i386
                 Recommends: libosmesa6:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

hamed@Hamed-PC:~$ sudo apt-get install libglu1 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libglu1-mesa' instead of 'libglu1'
libglu1-mesa is already the newest version.
libglu1-mesa set to manually installed.
The following packages were automatically installed and are no longer required:      
 efibootmgr libatkmm-1.6-1 libcairomm-1.0-1 libglibmm-2.4-1c2a
 libpangomm-1.4-1 libsigc++-2.0-0c2a libtimezonemap1 sbsigntool secureboot-db
 Use 'apt-get autoremove' to remove them.
 0 upgraded, 0 newly installed, 0 to remove and 22 not upgraded.

hamed@Hamed-PC:~$ sudo apt-get install libosmesa6 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
   libosmesa6 : Depends: libglapi-mesa (= 10.1.3-0ubuntu0.4)
E: Unable to correct problems, you have held broken packages.

hamed@Hamed-PC:~$ sudo apt-get install libglapi-mesa 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
  libcogl15 : Depends: libgbm1 (>= 8.1~0) but it is not going to be installed
         Depends: libwayland-egl1-mesa (>= 10.0.2) or
                  libwayland-egl1
libegl1-mesa : Depends: libgbm1 (>= 7.11~1) but it is not going to be installed
            Recommends: libegl1-mesa-drivers
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

hamed@Hamed-PC:~$ sudo apt-get install libegl1-mesa-drivers 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
 efibootmgr libatkmm-1.6-1 libcairomm-1.0-1 libglibmm-2.4-1c2a
 libpangomm-1.4-1 libsigc++-2.0-0c2a libtimezonemap1 sbsigntool secureboot-db
 Use 'apt-get autoremove' to remove them.
   The following extra packages will be installed:
      libegl1-mesa libgl1-mesa-dri libgl1-mesa-glx libglamor0 libglapi-mesa
      libgles2-mesa libllvm3.4 libopenvg1-mesa libspice-server1
      libwayland-egl1-mesa xserver-xorg xserver-xorg-core xserver-xorg-input-evdev
      xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
      xserver-xorg-video-glamoregl xserver-xorg-video-intel
      xserver-xorg-video-mach64 xserver-xorg-video-mga
      xserver-xorg-video-modesetting xserver-xorg-video-neomagic
      xserver-xorg-video-nouveau xserver-xorg-video-openchrome
      xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
      xserver-xorg-video-s3 xserver-xorg-video-savage
      xserver-xorg-video-siliconmotion xserver-xorg-video-sis
      xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
      xserver-xorg-video-vesa
Suggested packages:
    libglide3 xfonts-100dpi xfonts-75dpi firmware-linux
The following packages will be REMOVED:
    libegl1-mesa-lts-vivid libgbm1-lts-vivid libgl1-mesa-dri-lts-vivid
    libgl1-mesa-glx-lts-vivid libglapi-mesa-lts-vivid libgles1-mesa-lts-vivid
    libgles2-mesa-lts-vivid libwayland-egl1-mesa-lts-vivid
    libxatracker2-lts-vivid xserver-xorg-core-lts-vivid
    xserver-xorg-input-all-lts-vivid xserver-xorg-input-evdev-lts-vivid
    xserver-xorg-input-mouse-lts-vivid xserver-xorg-input-synaptics-lts-vivid
    xserver-xorg-input-vmmouse-lts-vivid xserver-xorg-input-wacom-lts-vivid
    xserver-xorg-lts-vivid xserver-xorg-video-all-lts-vivid
    xserver-xorg-video-ati-lts-vivid xserver-xorg-video-cirrus-lts-vivid
    xserver-xorg-video-fbdev-lts-vivid xserver-xorg-video-intel-lts-vivid
    xserver-xorg-video-mach64-lts-vivid xserver-xorg-video-mga-lts-vivid
    xserver-xorg-video-neomagic-lts-vivid xserver-xorg-video-nouveau-lts-vivid
    xserver-xorg-video-openchrome-lts-vivid xserver-xorg-video-r128-lts-vivid
    xserver-xorg-video-radeon-lts-vivid xserver-xorg-video-savage-lts-vivid
    xserver-xorg-video-siliconmotion-lts-vivid
    xserver-xorg-video-sisusb-lts-vivid xserver-xorg-video-tdfx-lts-vivid
    xserver-xorg-video-trident-lts-vivid xserver-xorg-video-vesa-lts-vivid
    xserver-xorg-video-vmware-lts-vivid
The following NEW packages will be installed:
   libegl1-mesa libegl1-mesa-drivers libgl1-mesa-dri libgl1-mesa-glx libglamor0
   libglapi-mesa libgles2-mesa libllvm3.4 libopenvg1-mesa libspice-server1
   libwayland-egl1-mesa xserver-xorg xserver-xorg-core xserver-xorg-input-evdev
   xserver-xorg-video-ati xserver-xorg-video-cirrus xserver-xorg-video-fbdev
   xserver-xorg-video-glamoregl xserver-xorg-video-intel
   xserver-xorg-video-mach64 xserver-xorg-video-mga
   xserver-xorg-video-modesetting xserver-xorg-video-neomagic
   xserver-xorg-video-nouveau xserver-xorg-video-openchrome
   xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
  xserver-xorg-video-s3 xserver-xorg-video-savage
  xserver-xorg-video-siliconmotion xserver-xorg-video-sis
  xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
  xserver-xorg-video-vesa
0 upgraded, 36 newly installed, 36 to remove and 22 not upgraded.
Need to get 17.7 MB of archives.
After this operation, 51.1 MB of additional disk space will be used.
Do you want to continue? [Y/n]   

At this point, I could Install Wine, successfully. but after reboot, Touch-pad Driver was disabled.

For fix that, I try to install one of two related packages that was removed since installing wine. but after reboot, system stuck at the black screen and didn't boot.

 hamed@Hamed-PC:~$ sudo apt-get install xserver-xorg-input-mouse-lts-vivid xserver-xorg-input-synaptics-lts-vivid
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
   xserver-xorg-input-mouse-lts-vivid : Depends: xorg-input-abi-21
                                  Depends: xserver-xorg-core-lts-vivid (>= 2:1.16.99.901) but it is not going to be installed
   xserver-xorg-input-synaptics-lts-vivid : Depends: xorg-input-abi-21
                                      Depends: xserver-xorg-core-lts-vivid (>= 2:1.16.99.901) but it is not going to be installed
 E: Unable to correct problems, you have held broken packages.

hamed@Hamed-PC:~$ sudo apt-get install xorg-input-abi-21 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package xorg-input-abi-21 is a virtual package provided by:
   xserver-xorg-core-lts-vivid 2:1.17.1-0ubuntu3~trusty1
   xserver-xorg-core-lts-utopic 2:1.16.0-1ubuntu1.2~trusty2
You should explicitly select one to install.
E: Package 'xorg-input-abi-21' has no installation candidate

hamed@Hamed-PC:~$ sudo apt-get install xserver-xorg-core-lts-vivid
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
   efibootmgr gnome-power-manager gucharmap indicator-keyboard indicator-power
   libatkmm-1.6-1 libcairomm-1.0-1 libfs6 libgee2 libglibmm-2.4-1c2a
   libgucharmap-2-90-7 libpangomm-1.4-1 libsigc++-2.0-0c2a libtimezonemap1
   sbsigntool secureboot-db x11-apps x11-session-utils x11-xfs-utils xbitmaps
   xinit xinput
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
   libgbm1-lts-vivid libgl1-mesa-dri-lts-vivid
Suggested packages:
   xfonts-100dpi xfonts-75dpi
The following packages will be REMOVED:
   elementary-desktop libgl1-mesa-dri xorg xserver-xorg xserver-xorg-core
   xserver-xorg-input-evdev xserver-xorg-video-ati xserver-xorg-video-cirrus
   xserver-xorg-video-fbdev xserver-xorg-video-glamoregl
   xserver-xorg-video-intel xserver-xorg-video-mach64 xserver-xorg-video-mga
   xserver-xorg-video-modesetting xserver-xorg-video-neomagic
   xserver-xorg-video-nouveau xserver-xorg-video-openchrome
   xserver-xorg-video-qxl xserver-xorg-video-r128 xserver-xorg-video-radeon
   xserver-xorg-video-s3 xserver-xorg-video-savage
   xserver-xorg-video-siliconmotion xserver-xorg-video-sis
   xserver-xorg-video-sisusb xserver-xorg-video-tdfx xserver-xorg-video-trident
   xserver-xorg-video-vesa
The following NEW packages will be installed:
    libgbm1-lts-vivid libgl1-mesa-dri-lts-vivid xserver-xorg-core-lts-vivid
  0 upgraded, 3 newly installed, 28 to remove and 22 not upgraded.
Need to get 4,698 kB of archives.
After this operation, 27.2 MB disk space will be freed.
Do you want to continue? [Y/n] y
 Get:1 ir.archive.ubuntu.com/ubuntu/ trusty-updates/main libgl1-mesa-dri-lts-vivid amd64 10.5.2-0ubuntu1~trusty1 [3,378 kB]
 32% [1 libgl1-mesa-dri-lts-vivid 1,525 kB/3,378 kB 45%]  
 35% [1 libgl1-mesa-dri-lts-vivid 1,660 kB/3,378 kB 49%]      
 37% [1 libgl1-mesa-dri-lts-vivid 1,735 kB/3,378 kB 51%]     
 40% [1 libgl1-mesa-dri-lts-vivid 1,901 kB/3,378 kB 56%]      
 43% [1 libgl1-mesa-dri-lts-vivid 2,020 kB/3,378 kB 60%]     
 46% [1 libgl1-mesa-dri-lts-vivid 2,151 kB/3,378 kB 64%]
 49% [1 libgl1-mesa-dri-lts-vivid 2,312 kB/3,378 kB 68%]      
 53% [1 libgl1-mesa-dri-lts-vivid 2,472 kB/3,378 kB 73%]    
 56% [1 libgl1-mesa-dri-lts-vivid 2,623 kB/3,378 kB 78%] 
 59% [1 libgl1-mesa-dri-lts-vivid 2,769 kB/3,378 kB 82%] 
 62% [1 libgl1-mesa-dri-lts-vivid 2,920 kB/3,378 kB 86%]   
 65% [1 libgl1-mesa-dri-lts-vivid 3,063 kB/3,378 kB 91%] 
 68% [1 libgl1-mesa-dri-lts-vivid 3,207 kB/3,378 kB 95%]  
 71% [1 libgl1-mesa-dri-lts-vivid 3,358 kB/3,378 kB 99%] 
 72% [Working]           
 Get:2 ir.archive.ubuntu.com/ubuntu/ trusty-updates/main libgbm1-lts-vivid amd64 10.5.2-0ubuntu1~trusty1 [24.2 kB]
 72% [2 libgbm1-lts-vivid 1,176 B/24.2 kB 5%]  
 72% [Working]   
 Get:3 ir.archive.ubuntu.com/ubuntu/ trusty-updates/main xserver-xorg-core-lts-vivid amd64 2:1.17.1-0ubuntu3~trusty1 [1,296 kB]
 72% [3 xserver-xorg-core-lts-vivid 1,172 B/1,296 kB 0%]   
 76% [3 xserver-xorg-core-lts-vivid 161 kB/1,296 kB 12%]   
 79% [3 xserver-xorg-core-lts-vivid 324 kB/1,296 kB 25%]  
 83% [3 xserver-xorg-core-lts-vivid 486 kB/1,296 kB 38%]   
 86% [3 xserver-xorg-core-lts-vivid 649 kB/1,296 kB 50%]    
 90% [3 xserver-xorg-core-lts-vivid 813 kB/1,296 kB 63%]   
 93% [3 xserver-xorg-core-lts-vivid 975 kB/1,296 kB 75%]    
 97% [3 xserver-xorg-core-lts-vivid 1,139 kB/1,296 kB 88%]      
 100% [Working]                                                                                                                   
  Fetched 4,698 kB in 17s (272 kB/s)
  (Reading database ... 131490 files and directories currently installed.)
 Removing elementary-desktop (1.379+426~ubuntu0.3.1) ...
Removing xorg (1:7.7+1ubuntu8.1) ...
Removing xserver-xorg (1:7.7+1ubuntu8.1) ...
Removing xserver-xorg-video-intel (2:2.99.910-0ubuntu1.6+elementary0.3.1) ...
Removing xserver-xorg-video-ati (1:7.3.0-1ubuntu3.1) ...
Removing xserver-xorg-video-radeon (1:7.3.0-1ubuntu3.1) ...
Removing xserver-xorg-input-evdev (1:2.8.2-1ubuntu2) ...
dpkg: xserver-xorg-core: dependency problems, but removing anyway as you requested:
 xserver-xorg-video-siliconmotion depends on xorg-video-abi-15; however:
 Package xorg-video-abi-15 is not installed.
 Package xserver-xorg-core which provides xorg-video-abi-15 is to be removed.
 xserver-xorg-video-siliconmotion depends on xserver-xorg-core (>= 2:1.14.99.902); however:
 Package xserver-xorg-core is to be removed.
 xserver-xorg-video-mach64 depends on xorg-video-abi-15; however:
 Package xorg-video-abi-15 is not installed.
 Package xserver-xorg-core which provides xorg-video-abi-15 is to be removed.
 xserver-xorg-video-mach64 depends on xserver-xorg-core (>= 2:1.14.99.902); however:
 Package xserver-xorg-core is to be removed.
 xserver-xorg-video-trident depends on xorg-video-abi-15; however:
 Package xorg-video-abi-15 is not installed.
 Package xserver-xorg-core which provides xorg-video-abi-15 is to be removed.
 xserver-xorg-video-trident depends on xserver-xorg-core (>= 2:1.14.99.902); however:
  Package
  Removing xserver-xorg-core (2:1.15.1-0ubuntu2.7) ...
  dpkg: libgl1-mesa-dri:amd64: dependency problems, but removing anyway as you requested:
  libgbm1:amd64 depends on libgl1-mesa-dri; however:
  Package libgl1-mesa-dri:amd64 is to be removed.
  Package libgl1-mesa-dri-lts-vivid:amd64 which provides libgl1-mesa-dri is not installed.
  libegl1-mesa-drivers:amd64 depends on libgl1-mesa-dri; however:
  Package libgl1-mesa-dri:amd64 is to be removed.
  Package libgl1-mesa-dri-lts-vivid:amd64 which provides libgl1-mesa-dri is not installed.
  Removing libgl1-mesa-dri:amd64 (10.1.3-0ubuntu0.4) ...
  Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
  Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
Selecting previously unselected package libgl1-mesa-dri-lts-vivid:amd64.
(Reading database ... 131329 files and directories currently installed.)
Preparing to unpack .../libgl1-mesa-dri-lts-vivid_10.5.2- 0ubuntu1~trusty1_amd64.deb ...
Unpacking libgl1-mesa-dri-lts-vivid:amd64 (10.5.2-0ubuntu1~trusty1) ...
(Reading database ... 131347 files and directories currently installed.)
Removing xserver-xorg-video-cirrus (1:1.5.2-1build1) ...
Removing xserver-xorg-video-fbdev (1:0.4.4-1build1) ...
Removing xserver-xorg-video-glamoregl (0.6.0-0ubuntu4) ...
Removing xserver-xorg-video-mach64 (6.9.4-1build1) ...
Removing xserver-xorg-video-mga (1:1.6.3-1build1) ...
Removing xserver-xorg-video-modesetting (0.8.1-1build1) ...
Removing xserver-xorg-video-neomagic (1:1.2.8-1build1) ...
Removing xserver-xorg-video-nouveau (1:1.0.10-1ubuntu2) ...
Removing xserver-xorg-video-openchrome (1:0.3.3-1build1) ...
Removing xserver-xorg-video-qxl (0.1.1-0ubuntu3) ...
Removing xserver-xorg-video-r128 (6.9.2-1build1) ...
Removing xserver-xorg-video-s3 (1:0.6.5-0ubuntu4) ...
Removing xserver-xorg-video-savage (1:2.3.7-2ubuntu2) ...
Removing xserver-xorg-video-siliconmotion (1:1.7.7-2build1) ...
Removing xserver-xorg-video-sis (1:0.10.7-0ubuntu6) ...
Removing xserver-xorg-video-sisusb (1:0.9.6-2build1) ...
Removing xserver-xorg-video-tdfx (1:1.4.5-1build1) ...
Removing xserver-xorg-video-trident (1:1.3.6-0ubuntu5) ...
Removing xserver-xorg-video-vesa (1:2.3.3-1build1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
Selecting previously unselected package libgbm1-lts-vivid:amd64.
(Reading database ... 131201 files and directories currently installed.)
Preparing to unpack .../libgbm1-lts-vivid_10.5.2-0ubuntu1~trusty1_amd64.deb ...
 Adding 'diversion of /usr/lib/x86_64-linux-gnu/libgbm.so.1.0.0 to /usr/lib/x86_64-linux-gnu/old.libgbm.so.1.0.0 by libgbm1-lts-vivid'
 Adding 'diversion of /usr/lib/x86_64-linux-gnu/libgbm.so.1 to /usr/lib/x86_64-linux-gnu/old.libgbm.so.1 by libgbm1-lts-vivid'
 Adding 'diversion of /usr/lib/x86_64-linux-gnu/gbm/gbm_gallium_drm.so to /usr/lib/x86_64-linux-gnu/gbm/old.gbm_gallium_drm.so by libgbm1-lts-vivid'
 Unpacking libgbm1-lts-vivid:amd64 (10.5.2-0ubuntu1~trusty1) ...
 Selecting previously unselected package xserver-xorg-core-lts-vivid.
 Preparing to unpack .../xserver-xorg-core-lts-vivid_2%3a1.17.1-0ubuntu3~trusty1_amd64.deb ...
Unpacking xserver-xorg-core-lts-vivid (2:1.17.1-0ubuntu3~trusty1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libgl1-mesa-dri-lts-vivid:amd64 (10.5.2-0ubuntu1~trusty1) ...
Installing new version of config file /etc/drirc ...
Setting up libgbm1-lts-vivid:amd64 (10.5.2-0ubuntu1~trusty1) ...
Setting up xserver-xorg-core-lts-vivid (2:1.17.1-0ubuntu3~trusty1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.6) ...

hamed@Hamed-PC:~$ sudo apt-get install xserver-xorg-input-mouse-lts-vivid xserver-xorg-input-synaptics-lts-vivid 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  efibootmgr gnome-power-manager gucharmap indicator-keyboard indicator-power
  libatkmm-1.6-1 libcairomm-1.0-1 libfs6 libgee2 libglamor0 libglibmm-2.4-1c2a
  libgucharmap-2-90-7 libpangomm-1.4-1 libsigc++-2.0-0c2a libspice-server1
  libtimezonemap1 libxvmc1 sbsigntool secureboot-db x11-apps x11-session-utils
  x11-xfs-utils xbitmaps xinit xinput
Use 'apt-get autoremove' to remove them.
Suggested packages:
  gpointing-device-settings touchfreeze
The following NEW packages will be installed:
 xserver-xorg-input-mouse-lts-vivid xserver-xorg-input-synaptics-lts-vivid
0 upgraded, 2 newly installed, 0 to remove and 22 not upgraded.
Need to get 99.0 kB of archives.
After this operation, 369 kB of additional disk space will be used.
Get:1 ir.archive.ubuntu.com/ubuntu/ trusty-updates/main xserver-xorg-input-mouse-lts-vivid amd64 1:1.9.1-1~trusty1 [37.7 kB]
Get:2 ir.archive.ubuntu.com/ubuntu/ trusty-updates/main xserver-xorg-input-synaptics-lts-vivid amd64 1.8.1-1ubuntu1~trusty1 [61.3 kB]
 Fetched 99.0 kB in 1s (73.9 kB/s)                                
 Selecting previously unselected package xserver-xorg-input-mouse-lts-vivid.
(Reading database ... 131247 files and directories currently installed.)
Preparing to unpack .../xserver-xorg-input-mouse-lts-vivid_1%3a1.9.1-1~trusty1_amd64.deb ...
Unpacking xserver-xorg-input-mouse-lts-vivid (1:1.9.1-1~trusty1) ...
Selecting previously unselected package xserver-xorg-input-synaptics-lts-vivid.
Preparing to unpack .../xserver-xorg-input-synaptics-lts-vivid_1.8.1-1ubuntu1~trusty1_amd64.deb ...
Unpacking xserver-xorg-input-synaptics-lts-vivid (1.8.1-1ubuntu1~trusty1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up xserver-xorg-input-mouse-lts-vivid (1:1.9.1-1~trusty1) ...
Setting up xserver-xorg-input-synaptics-lts-vivid (1.8.1-1ubuntu1~trusty1) ...
  • 1
    Could you (at least try to) explain more clearly what the actual problem is in plain words, so that we don't have to scan through two huge logs without spacing or any explanation? – RolandiXor Oct 7 '15 at 19:46
  • please report back when you are active, Hamed . Ping me with @Ravan. – Ravan Nov 25 '15 at 14:11
1

I had the same dependency problem.But instead of fighting with the dependencies I added the ubuntu-wine PPA by using sudo add-apt-repository ppa:ubuntu-wine/ppa -y && sudo apt-get update && sudo apt-get install wine(which I found at https://askubuntu.com/questions/316025/how-to-install-and-configure-wine).

So I recommend you roll-back your changes and run sudo add-apt-repository ppa:ubuntu-wine/ppa -y && sudo apt-get update && sudo apt-get install wine(which didn't break the touchpad (synaptics) on my laptop)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.