I've encountered something when using Pantheon Terminal. Normally, I expect Ctrl+D to delete the character at point if there is one, else if there aren't any characters on the line, send EOF (standard bash keyboard shortcut). However, it looks like the standard keyboard shortcuts for pantheon-terminal include Ctrl+D to directly close the current tab.

My shell is set to /bin/bash

> env | grep -i shell

and I've checked for options using dconf-editor under org.pantheon.terminal.settings and couldn't find anything to help create the behavior I expect.

How can I disable Ctrl+D closing the terminal tab so I that it behaves how I expect it to?

  • @LewisGoddard et al. Why was this closed? “Change the default behavior of Terminal” would be a feature request, but this question is asking how to change it in one user's settings, that's a how-to question, not a feature request. Commented Oct 6, 2015 at 23:16
  • @Gilles I have re-opened the question, and will leave it to the community to close it again. Asking for a workaround is no different to a feature request, except the lack of care about the source of the instruction. Plus, I don't think this is possible with the current code.
    – Lewis Goddard
    Commented Oct 6, 2015 at 23:53
  • Thanks for re-opening this @Gilles, looks like someone was able to provide an answer.
    – Cass
    Commented Oct 7, 2015 at 22:34

1 Answer 1


You can disable save-exited-tabs and then Ctrl+D can be used for bash. Just run:

gsettings set org.pantheon.terminal.settings save-exited-tabs false

  • 1
    Thank you @Djax, worked like a charm. I also would have never come to the conclusion that this would've fixed it. Any idea if this will have any side affects I might not be aware of? If not, I think I'm set.
    – Cass
    Commented Oct 7, 2015 at 22:30
  • Not working for me. After executing that command, Ctrl+D still close my terminal. Very annoying.
    – jgomo3
    Commented Jul 19, 2016 at 3:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.