0

I installed Libreoffice via PPA (ppa:libreoffice/ppa) and all installed fine. Running "apt upgrade" afterwards, everything was fine. Then after a recent update something seems to have broken and I cannot update any applications due to Libreoffice being broken.

FYI I have also added the below PPAs to my system since installing: ppa:philip.scott/elementary-tweaks ppa:papirus/papirus

Can anyone recommend how I can fix my system? And any tips on avoiding this happening again?

I'm getting the below error message when running "apt upgrade":

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.

The following packages have unmet dependencies:

libreoffice-base : Depends: libreoffice-common (>= 1:6.4.0~beta1-2~) but 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1 is installed
                    Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                    Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                    Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                    Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                    Depends: uno-libs-private but it is not installed
                    Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1 is installed
                    Recommends: libreoffice-java-common (>= 1:6.4.2~) but 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1 is installed

libreoffice-base-core : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                         Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                         Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                         Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                         Depends: uno-libs-private but it is not installed

libreoffice-base-drivers : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                            Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                            Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
                            Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                            Depends: uno-libs-private but it is not installed

libreoffice-calc : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                    Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                    Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
                    Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
                    Depends: uno-libs-private but it is not installed
                    Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1 is installed

libreoffice-common : Breaks: libreoffice-core (>= 1:6.4~) but 1:6.4.2-0ubuntu0.18.04.2 is installed
                      Breaks: libreoffice-style-tango (>= 1:6.4~) but 1:6.4.2-0ubuntu0.18.04.2 is installed

libreoffice-core : Depends: libreoffice-common (> 1:6.4.2) but 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1 is installed
                    Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                    Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                    Depends: libuno-sal3 (>= 6.4.0~beta) but it is not installed
                    Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
                    Depends: uno-libs-private but it is not installed

libreoffice-draw : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                    Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                    Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
                    Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
                    Depends: uno-libs-private but it is not installed
                    Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1 is installed

libreoffice-gnome : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                     Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                     Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                     Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                     Depends: uno-libs-private but it is not installed

libreoffice-gtk3 : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                    Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                    Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                    Depends: uno-libs-private but it is not installed

libreoffice-impress : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                       Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                       Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
                       Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                       Depends: uno-libs-private but it is not installed
                       Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1 is installed

libreoffice-math : Depends: libreoffice-core (= 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1) but 1:6.4.2-0ubuntu0.18.04.2 is installed

libreoffice-report-builder-bin : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                                  Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                                  Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                                  Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                                  Depends: uno-libs-private but it is not installed

libreoffice-sdbc-firebird : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                             Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                             Depends: libuno-sal3 (>= 5.1.0~alpha) but it is not installed
                             Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                             Depends: uno-libs-private but it is not installed

libreoffice-sdbc-mysql : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                          Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                          Depends: libuno-sal3 (>= 4.2.0~rc1) but it is not installed
                          Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                          Depends: uno-libs-private but it is not installed

libreoffice-sdbc-postgresql : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                               Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
                               Depends: libuno-sal3 (>= 4.1.0~alpha) but it is not installed
                               Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                               Depends: uno-libs-private but it is not installed

libreoffice-writer : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
                      Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
                      Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
                      Depends: libuno-salhelpergcc3-3 (>= 1.4.0) but it is not installed
                      Depends: uno-libs-private but it is not installed
                      Breaks: libreoffice-common (< 1:6.4.2~rc1~) but 1:6.3.5~rc2-0ubuntu0.18.04.1~lo1 is installed

python3-uno : Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
               Depends: libuno-cppuhelpergcc3-3 (>= 5.3.0~alpha) but it is not installed
               Depends: libuno-sal3 (>= 5.4.0~alpha) but it is not installed
               Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
               Depends: uno-libs-private but it is not installed

ure : Depends: uno-libs-private (= 1:6.4.2-0ubuntu0.18.04.2) but it is not installed
       Depends: libuno-cppu3 (>= 4.4.0~alpha) but it is not installed
       Depends: libuno-cppuhelpergcc3-3 (>= 4.0.0~alpha) but it is not installed
       Depends: libuno-purpenvhelpergcc3-3 (>= 1.4.0) but it is not installed
       Depends: libuno-sal3 (>= 5.3.0~alpha) but it is not installed
       Depends: libuno-salhelpergcc3-3 (>= 3.6.0~beta) but it is not installed
       Recommends: libjuh-java but it is not installed
       Recommends: libjurt-java but it is not installed
       Recommends: libridl-java but it is not installed
       Recommends: libunoloader-java but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

Thanks!

Mark

  • Oh also I've tried "apt --fix-broken install" and it also throws an error as well – Mark Mar 28 at 10:40
  • Okay, this is weird I just ran it again to get the error message and it has actually fixed my system now. Can anyone advise how ti would suddenly fix itself. Literally haven't changed anything and the same commands that were throwing an error have now worked?? – Mark Mar 28 at 10:42
  • Did you run the command it told you to try?: run 'apt --fix-broken install' – Paul Apr 8 at 2:06
  • I think you should uninstall LibreOffice and disable the PPA. Then install the latest version through: flathub.org/home – Storm Apr 10 at 4:14
1

Okay, this is weird I just ran it again to get the error message and it has actually fixed my system now. Can anyone advise how it would suddenly fix itself. Literally haven't changed anything and the same commands that were throwing an error have now worked??

As said in your comments since it is fixed I would recommend installing LibreOffice from Flathub as AppCenter now integrates with Flatpak very well.

As an alternative I would recommend that you try out LibreOffice AppImage as it does not mess with your system, so it's least likely that any AppImage can break your system.

PPA are not recommended. Even Ubuntu is moving towards Snap.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.