0

****Which version of Elementary OS should I use to match my PC? I am using SONY with Intel Core2Duo Processor E7200 (2.53 GHz.), memory 2 GB. And I have 320 GB HDD.****

0

You should be able to run 5.1.3 Hera.

Here are the specs you need:

  • Recent Intel i3 or comparable dual-core 64-bit processor
  • 4 GB of system memory (RAM)
  • Solid state drive (SSD) with 15 GB of free space
  • 1024×768 display

https://elementary.io/docs/installation#installation

0
  • Please make your title clearer to address your problem. A better title would’ve been “I’m running on a low-spec PC, should I downgrade my version of Elementary OS?”

Yes — for the most part. You should be able to run Elementary OS with 2 GBs of RAM but —— as per the website —— 4 GB is recommended for comfortable usage of Elementary OS

However, you should add more detail because there is one thing I can’t answer —— graphics card compatibility. You need to be able to run at least 720p display resolution with your graphics card for Elementary OS to function properly/look proper (also mentioned on the website) and you need a display that can support that resolution

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.