0
The following packages have unmet dependencies:
 wine-stable : Depends: wine-stable-i386 (= 5.0.0~eoan)
               Depends: wine-stable-amd64 (= 5.0.0~eoan) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
snawaz@snawaz-Presario-CQ56-Notebook-PC:~$ 
  • What tutorial did you follow? elementary OS is based on Ubuntu 18.04, so whenever you add ppas, look for the instructions for bionic, not eoan. – Vlad Pop Mar 24 at 13:36
1

As far I understand the issue, it is caused because of a missing dependence in Ubuntu 18.04 on which elementary OS Hera is based on. Wine after 4.5 seems to need libfaudio to be working. You can download it from the link below and use Eddy to install the package (just click on the downloaded file), but remember, this is not an official Ubuntu or elementary OS repository! Installing software from not official repositories may be a risk!

https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/i386/

The files that you will need are: libfaudio0_19.07-0~bionic_amd64.deb and libfaudio0_19.07-0~bionic_i386.deb

In case after installation of one of the files Eddy will not install the second (it will show that it is already installed) you will need to use the command line. In this case follow this instruction: 1. Go to the destination folder where you downloaded the file, by using the "cd" command. Example:

cd /home/username/Downloads

  1. Then install the deb file. Example:

sudo dpkg -i libfaudio0_19.07-0~bionic_i386.deb

I found the solution by visiting the following links: https://forum.winehq.org/viewtopic.php?t=32061 https://forum.winehq.org/viewtopic.php?f=8&t=32192

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.