0

Since kernel 4.15.0.55 update, I'm getting stuck at boot. No kenel after .55 can't boot. At recovery mode system halts at this message:

r8169 can't disable ASPM OS doesn't have ASPM control

I've found this is a long lasting bug. I've installed r8168-dkms (8.045.08-2ubuntu1) with synaptic package manager, but I've seen r8168 don't replace r8169, and boot halts at same point. I've found a forum post pointing to install r8168-dkms_8.047.02-1_all.deb, instead, but I'm not sure about this workaround.

    dmesg | grep r816
    [    2.909400] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
    [    2.909416] r8169 0000:03:00.2: can't disable ASPM; OS doesn't have ASPM control
    [    2.910627] r8169 0000:03:00.2 eth0: RTL8402 at 0x        (ptrval), 1c:b7:2c:0f:6a:c8, XID 04000800 IRQ 89
    [    3.050940] r8169 0000:03:00.2 enp3s0f2: renamed from eth0
    [  214.785516] r8169 0000:03:00.2 enp3s0f2: link down
    [ 5487.302121] r8169 0000:03:00.2 enp3s0f2: link down

Edit:

Also I've found a solution at github "Linux driver for Realtek network chips with enabled ASPM", but not tried yet

Any advice?

0

I have installed Linux-generic-hwe-18.04, and now I can boot without any problem. It has been solved since kernel 4.19

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.