0

My laptop is Lenovo Ideapad C340 and i have installed elementary OS 5.1 Hera. The Wifi works out of the box.

However when i updated the suggested updates from the AppCenter two days back wifi card disappeared.

When i reinstall the elementary OS 5.1 Hera wifi works and if i update wifi stops.

I tried several methods described to correct the problem none seems to work.

my wifi card details are

    description: Wireless interface
   product: Intel Corporation
   vendor: Intel Corporation
   physical id: 14.3
   bus info: pci@0000:00:14.3
   logical name: wlp0s20f3
   version: 00
   serial: 08:71:90:b9:86:56
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlwifi driverversion=5.3.0-28-generic firmware=48.13675109.0 ip=192.168.1.190 latency=0 link=yes multicast=yes wireless=IEEE 802.11
   resources: irq:16 memory:b4318000-b431bfff

So i would like your help in sorting this problem. I noticed that kernel is 5.3.0-28-generic and after the update is it 5.4 something .... it is the kernel update that breaks it ?

How to fix this much appreciated.

0

"I tried several methods described to correct the problem none seems to work. "

Can you explain a bit more?

| improve this answer | |
0

I have a new Asus ZenBook (just shipped) with an Intel 9000 series wireless adapter built in, and I had the same problem. I solved it by manually installing the backport of iwlwifi using the advice of "jeremy31" here:

https://askubuntu.com/questions/1046589/backport-for-iwlwifi

Note that the first recommended install didn't solve my problem; it was the second step (getting the newer version from Canonical) that actually solved my problem.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.