2

I ran sudo apt-get -y update && sudo apt-get -y upgrade around 2020-03-04T15:00:00Z, then rebooted my computer. The dock (plank) didn't show up, and the file manager (pantheon-files) is totally removed from my OS. I tried to fix this by running sudo apt-get -y update && sudo apt-get -y install pantheon-files, and it gave me the following log:

Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 pantheon-files : Depends: libplank1 (>= 0.11.89) but 0.11.4+git20190318.fb624c21-0elementary5.0.1 is to be installed
E: Unable to correct problems, you have held broken packages.

I checked the versions of libplank1, and at the time of writing this post, the highest version is 0.11.4-2 for Ubuntu Bionic.

How can I fix this?

UPDATE

Here's the output of sudo apt update:

Hit:1 http://packages.microsoft.com/repos/vscode stable InRelease
Get:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]                                                
Hit:3 http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic InRelease                                                
Hit:4 http://cn.archive.ubuntu.com/ubuntu bionic InRelease                                                                 
Hit:5 https://download.docker.com/linux/ubuntu bionic InRelease                                                            
Get:6 http://packages.elementary.io/appcenter bionic InRelease [5,893 B]                                                   
Ign:7 http://binaries.erlang-solutions.com/debian bionic InRelease                                                         
Get:8 https://repo.skype.com/deb stable InRelease [4,486 B]                                                                
Get:9 http://cn.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]                                               
Hit:10 http://binaries.erlang-solutions.com/debian bionic Release                                                          
Hit:11 http://ppa.launchpad.net/gregory-hainaut/pcsx2.official.ppa/ubuntu bionic InRelease                                 
Hit:12 http://ppa.launchpad.net/elementary-os/os-patches/ubuntu bionic InRelease                                           
Get:13 http://packages.elementary.io/appcenter bionic/main amd64 DEP-11 Metadata [234 kB]                  
Get:14 https://repo.skype.com/deb stable/main amd64 Packages [2,255 B]                                                     
Get:16 http://cn.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]                                            
Get:17 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [38.5 kB]
Get:18 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 48x48 Icons [17.6 kB]
Get:19 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 64x64 Icons [41.5 kB]
Get:20 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 128x128 Icons [97.7 kB]     
Get:21 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [42.1 kB]   
Get:22 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [16.4 kB]           
Get:23 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [111 kB]            
Get:24 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 128x128 Icons [181 kB]                   
Get:25 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2,464 B]
Get:26 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [871 kB]
Get:27 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [651 kB]
Get:28 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [307 kB]
Get:29 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [73.8 kB]
Get:30 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [140 kB]
Get:31 http://cn.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 128x128 Icons [358 kB]
Get:32 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [1,054 kB]
Get:33 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [1,010 kB]
Get:34 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [264 kB]
Get:35 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [194 kB]
Get:36 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [453 kB]
Get:37 http://cn.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 128x128 Icons [988 kB]
Get:38 http://cn.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:39 http://cn.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [7,980 B]
Fetched 7,422 kB in 6s (1,316 kB/s)                                         
Reading package lists... Done
Building dependency tree       
Reading state information... Done

And apt-cache policy plank shows

plank:
  Installed: 0.11.4+git20190318.fb624c21-0elementary5.0.1
  Candidate: 0.11.4+git20190318.fb624c21-0elementary5.0.1
  Version table:
 *** 0.11.4+git20190318.fb624c21-0elementary5.0.1 500
        500 http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic/main amd64 Packages
        100 /var/lib/dpkg/status
     0.11.4-2 500
        500 http://cn.archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

And apt-cache policy pantheon-files shows

pantheon-files:
  Installed: (none)
  Candidate: 4.4.1+r3712+pkg91~ubuntu5.1.2.1
  Version table:
     4.4.1+r3712+pkg91~ubuntu5.1.2.1 500
        500 http://ppa.launchpad.net/elementary-os/stable/ubuntu bionic/main amd64 Packages
| improve this question | | | | |
  • Me either i had the same problem today!! – Guest Mar 4 at 21:18
  • Can you run sudo apt update and post the output so that I can confirm you have all the right software sources? You should have the latest plank available from our os-patches PPA. In general, it's not a good idea to run apt commands with -y because you won't get a chance to verify that the command isn't asking you to remove packages. – Daniel Foré Mar 4 at 22:46
  • @DanielForé apt update output added. – Aetherus Zhou Mar 4 at 22:54
  • The output of apt-cache policy plank would also be useful – David Hewitt Mar 4 at 23:00
  • 1
    In that case, you should be able to completely remove the apt caches by running sudo rm -rf /var/lib/apt/lists/*. Running sudo apt update after this will recreate those caches that seem to be causing issues and hopefully the new version will be available. – David Hewitt Mar 5 at 18:19
1

This was resolved in the comments on the question, posting answer here for posterity. The issue was a corrupt apt cache.

The required version of plank comes from the elementary/os-patches repository, which we could see was correctly available on the system from the apt update output.

Despite successful runs of apt update, running apt-cache policy plank was still only showing version 0.11.4 as the latest version available when, in fact, 0.11.89 is available in the repository and this is the required version.

Clearing the apt caches by running sudo rm -rf /var/lib/apt/lists/* and then running sudo apt update again was enough to get apt to regenerate its repository caches and see the new version of plank. Files and plank could then be reinstalled.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.