Has anybody got xrdp to work with 5.1 and if so how?

I've tried: apt install xrdp apt install xorgxrdp-hwe-18.04

ufw allow 3389/tcp

And all I get is a blank screen. I can get xrdp to work on other flavors of Ubuntu,but no joy with this one.

Many thanks Chirs

1 Answer 1


I am experiencing the same thing. Given that this hasn't been answered in nearly a year doesn't bode well for me. I am considering installing elementaryOS 5.1 (hera) on a Dell server-class machine, to which I will want to RDP to so I can use the desktop environment. I installed the latest version of XRDP (v0.9.15), set the firewall to allow port 3389, added the xrdp user to the ssl-cert group, enabled xrdp, checked that it was running, and all I've gotten is the black screen.

Actually, if I let the screen sit for a few minutes, I receive an error message, which when I click on it, shows me an xorg logon screen, but none of the options there does any better than the black screen. Hmmm.

  • I don't think this is much of an answer, per say.
    – jwillikers
    Feb 15, 2021 at 12:11
  • To be honest I've not tried XRDP on ElementaryOS (or even played with ElementryOS) since last year. I've always found XDRP to be very hit and miss. When it works it very good so I try to get it to work on the different distros that I try. I will give it another go this week and see if I can get it working. If I do I will give you my scripts.
    – Chris
    Feb 17, 2021 at 9:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.