2

Since switching from Windows a few weeks ago, I've been using eOS on this laptop without issue. However, after downloading system updates a couple of days ago, the system wouldn't boot, hanging on a black screen and never making it to the eOS logo. I reinstalled the OS, and it booted fine. However, once I downloaded system updates, the issue reappeared.

If I use recovery mode, it boots successfully. If I do a fresh install using the most recent iso and don't install third-party drivers or system updates, it boots successfully. If I install third-party drivers during the installation process, or if I download system updates after booting, the next boot fails.

The laptop has Ryzen 3 3200u with Radeon Vega 3 graphics.

Any and all help would be greatly appreciated.

0

i just experienced the same today after performing a log in, the black screen appeared, I left the black screen for about 5 min while pressing random keys on the KB and after a while the desktop came up.

I'm currently using it normally haven't tried to reboot yet.

It's possible that yesterdays updates may have been finalizing after the power up/ reboot and had taken a while to complete.

Will test again this afternoon and if the problem persists will report back.

A complete reinstall is a little over kill there are other methods of troubleshooting that should be tried 1st before resorting to a full reinstall.

""Cheers G

| improve this answer | |
0

First unplug all USB devices and try to boot again. I had a similar thing happen and it turned out to be my USB midi controller keeping it from booting for some reason. If that makes no difference, boot into recovery mode and disable the boot splash screen following the directions at http://ubuntuhandbook.org/index.php/2019/06/disable-purple-splash-screen-boot-ubuntu-18-04-higher/ This way you will have a clearer picture as to what the system is hanging on while booting.

| improve this answer | |
0

I'm experiencing exactly the same problem on an Alienware 17 R5.

For what it's worth, the deadly update contained the following packages:

2020-07-25 16:14:21 install linux-modules-5.4.0-42-generic:amd64 <none> 5.4.0-42.46~18.04.1
2020-07-25 16:14:22 install linux-image-5.4.0-42-generic:amd64 <none> 5.4.0-42.46~18.04.1
2020-07-25 16:14:22 install linux-modules-extra-5.4.0-42-generic:amd64 <none> 5.4.0-42.46~18.04.1
2020-07-25 16:14:25 install linux-hwe-5.4-headers-5.4.0-42:all <none> 5.4.0-42.46~18.04.1

A kind fellow Linux user on Twitter gave me the idea for the fix.

  • Boot into recovery mode (Should be the entry right after the current one in Grub with the word 'recovery' at the end).
  • Enable networking (Should be on the recovery boot menu you see)
  • Run ubuntu-drivers install

In my case, I'd been running the 435 nvidia driver and this command properly installed the 440 driver, fixing my problem.

Hope this helps!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.