1

Okay, so ill cut this short. I had switched from Windows 10 to elementaryOS because windows had gotten laggy. After switching, i realized there weren't a lot of games and couldn't use Wine so Ubuntu was my option. I installed Ubuntu on a USB with UNetbootin and tried to boot the USB drive. And the roadblock. When i manually booted via boot menu, the computer jumps right in to elementaryOS. I'm just looking for a solution to this problem.

2

First, don't use unetbootin unless a distro specifically requests it. On Linux, your best bet is to just use DD (google how to do it with an iso), or use gnome disk utility (google it as well), or BalenaEtcher. On Windows, use Rufus, or again, use whatever method the install guide for the Distro recommends.

Secondly, Elementary is based on Ubuntu LTS. Anything that works on Ubuntu, works on eOS (usually except the occasional bugs). I've personally had no issues installing Wine, Lutris, and Steam on eOS. Both Lutris and Wine has install guides how to do it.

14
  • I used Startup Disk Creator (installed via Terminal) and it seems like it worked, but it jumps into elementaryOS, even with manually booting. I want to try/install Ubuntu to play Minecraft and i like the Ubuntu interface more because it looks a bit like the Windows 10 interface.
    – ElectriX
    Feb 22 '20 at 14:22
  • Are you sure you're picking the USB stikc in the boot order of your BIOS? Might also be the flash drive that's borked. Try another, or create a CD/DVD instead.
    – user20763
    Feb 22 '20 at 15:00
  • Im pretty sure I am, because Startup Disk Creator, Etcher, ISO burner and boot menu says its name as "Generic USB Device" and its the only removable drive i have plugged in. And, I dont have another USB Drive, maybe ill buy one tomorrow
    – ElectriX
    Feb 22 '20 at 15:02
  • Third option is BIOS vs UEFI. Which one do you have? I'm not sure how Startup Disk Creator does it, but if the created media is for UEFI, and you're BIOS, that might be why. UEFI usually supports both, but BIOS doesn't support UEFI.
    – user20763
    Feb 22 '20 at 15:04
  • I have BIOS, the created media is Ubuntu 19.10, i dont know if its UEFI or BIOS.
    – ElectriX
    Feb 22 '20 at 15:21
0

Seems you're problem is about the boot media, not about elementary.

Don't use UNetbootin, which usually fails. Use Etcher which usually is better.

Either way, elementaryOS is based on Ubuntu, so if anything runs on Ubuntu it runs on elementary. I use elementaryOS and play a lot of games in Steam via Proton (a utility developed by Valve to run games via Wine) and I'm very happy.

1
  • First time it said isolinux.bin was corrupt. I downloaded another version and then it started happening again, PC started booting to elementaryOS instead. I tried downloading the same version again, and yes i used Etcher.
    – ElectriX
    Feb 21 '20 at 14:15
0

I'll echo babel's comments. I haven't found anything in a debian or ubuntu package that doesn't install in elementary. I think wine is even in the App Center.

That being said, I did a lot of distro hopping before settling on elementary OS and I often find that nothing will work. Just a few days ago I had to wipe a drive that had OpenSUSE on it to install elementary OS. It SHOULD have worked by booting from the USB, but it didn't despite all the fiddling around with the BIOS. I've found this on all kinds of distros. I've had the same USB work on one computer and not another.

In short, and assuming you have exhausted the options in your BIOS, wipe the destination drive and try again.

2
  • Trust me, i've tried multiple times to wipe the entire USB drive and re-burned it. It just boots straight into elementaryOS
    – ElectriX
    Feb 21 '20 at 14:11
  • I meant the NVME. Wipe that before you try to install on it.
    – riff raff
    Feb 23 '20 at 18:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.