0

Yesterday there were 9 system upgrades in the AppCenter. I upgraded, but org.gnome.Platform Flatpak runtime was still listed. I tried again, and it remains there waiting for upgrade. Also might maybe be relevant to mention: since some days after I press the upgrade button it starts immediately to fill the blue bar (downloading, installing etc) WITHOUT ASKING for the authentication, as usually. After that it does NOT crash, as it did some time ago, but it also does NOT update. Flatpak runtime remains there, AppCenter remains open, update button is visible.

Today I tried the solution suggested on the chosen answer of this thread and here's the terminal output:

master@elm:~$ flatpak install org.freedesktop.Platform/x86_64/19.08 Looking for matches… Found similar ref(s) for ‘org.freedesktop.Platform/x86_64/19.08’ in remote ‘flathub’ (user). Use this remote? [Y/n]: y

    ID                                  Branch   Op   Remote   Download

1. [✓] org.freedesktop.Platform.Locale 19.08 i flathub 16,7 kB / 318,2 MB

  1. [✗] org.freedesktop.Platform.openh264 19.08 i flathub 593,6 kB / 593,4 kB

  2. [✓] org.freedesktop.Platform 19.08 i flathub 11,4 MB / 238,1 MB

Warning: org.freedesktop.Platform.openh264 not installed Installation complete.

master@elm:~$ flatpak uninstall --unused

    ID                                              Branch          Op

1. [-] org.freedesktop.Platform.VAAPI.Intel 18.08 r

  1. [-] org.freedesktop.Platform.html5-codecs 18.08 r

  2. [-] org.freedesktop.Platform 19.08 r

  3. [-] org.freedesktop.Platform.Locale 19.08 r

  4. [-] org.gnome.Platform 3.32 r

  5. [-] org.gnome.Platform.Locale 3.32 r

Uninstall complete.

master@elm:~$ flatpak update Looking for updates…

    ID                                  Branch   Op   Remote   Download

1. [✗] org.freedesktop.Platform.openh264 19.08 i flathub 593,6 kB / 593,4 kB

Warning: org.freedesktop.Platform.openh264 not installed Installation complete.

master@elm:~$ sudo apt install org.freedesktop.Platform.openh264 [sudo] password for master:
Reading package lists... Done Building dependency tree
Reading state information... Done E: Unable to locate package org.freedesktop.Platform.openh264 E: Couldn't find any package by glob 'org.freedesktop.Platform.openh264' E: Couldn't find any package by regex 'org.freedesktop.Platform.openh264'

master@elm:~$ sudo flatpak repair Working on the system installation at /var/lib/flatpak Segmentation fault

master@elm:~$ flatpak update Looking for updates…

    ID                                  Branch   Op   Remote   Download

1. [✗] org.freedesktop.Platform.openh264 19.08 i flathub 593,6 kB / 593,4 kB

Warning: org.freedesktop.Platform.openh264 not installed Installation complete.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.