0

When trying Elementary OS 5.1 on a 2013 MacBook Air 13 (6,2) from a USB stick, everything seems to work, except for WiFi. The WiFi hardware does not show up at all.

There is a very similar question already, and it has an answer, but for a different version of Elementary OS (5.0). That solution removes the bcmwl-kernel-source package and installs firmware-b43-installer, but 5.1 does not include bcmwl-kernel-source.

  • try installing 'broadcom-sta-dkms' instead. – Yasn Feb 13 at 22:35
  • I don't know what to remove though. I haven't tried installing anything yet. – Carl Smith Feb 13 at 23:38
  • have you installed eOS on the USB stick with the same machine? – Yasn Feb 14 at 9:10
  • Nope. I created the USB stick using an older version of Ubuntu, then replaced that Ubuntu with eOS, all on an old Toshiba Satellite. When I tried the USB stick with my MacBook Air, it didn't detect the WiFi antenna. – Carl Smith Feb 17 at 1:21
  • I just remembered that the WiFi antenna wasn't detected on the Toshiba either, but I plugged in an external USB antenna, and that worked fine. – Carl Smith Feb 17 at 1:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.