1

I have some experience setting up Windows Linux Dual boot, but unfortunately yesterday I ran into a problem. The grub menu does not have Windows 7 on it, and I don't know how to get it on there. I installed a new version of Linux onto an old laptop. The laptop does not have UEFI, it has the old BIOS system only, and I think the grub menu installation expected the Windows to have an entry in an ESP partition maybe. I don't know. There was no ESP partition prior to installing Linux ElementaryOS (an ubuntu variant)

This is for a client, and his applications on the Windows partition are important for his business, he cannot lose them, so we cannot merely reinstall Windows 7 and clear the system. How do I get Windows 7 on the Grub menu, or just go back to booting directly into Windows 7?

Lenovo laptop, very old, Windows 7 OEM 64-bit BIOS Only, no UEFI 4Gb RAM Intel i3 2gz

I have already attempted to use: Boot-Recovery Live CD (automated repair with the new and old versions) Boot Ice (don't know the exact steps to take) Windows 10 automated Startup Repair

If you have a solution, even if it means only booting to Windows 7, and never again to ElementaryOS, this client would be OK with that. We are desparate and short on time to fix this, so he can get back to his Windows applications. I use mostly linux at home, but he needs a couple Windows applications for his work.

Thank you for all your help!

0

From the linux system (NOT THE LIVE CD), try running:

sudo update-grub

You might need to manually mount the (Windows) partition before running that command, I had mixed results in the past. But 99.99% of the times, it founds the windows partition (if it's there) and add the grub entry.

-Aldo

| improve this answer | |
  • 1
    Yes of course I already tried sudo update-grub before posting this. I resolved the issue by myself. I am not sure, but I believe the core issue was that I was attempting to create the mbr too far from the beginning of the disk. – Sandcastle Mar 21 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.