1

I've read through the answers to similar questions here, but I still haven't figured this out. I installed Steam via the AppCenter, and it seemed to go okay - I managed to get to the login screen and get my account connected, but then ... nothing. When I launch via app, the icon appears in the dock for maybe 10 seconds then disappears. When I launch via Terminal, I get this:

Running Steam on elementary 5.1 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
/home/gareth/.local/share/Steam/ubuntu12_32/steam

... and then nothing. I'm a Linux noob, but very capable and driven to fix problems, so would really appreciate some help.

  • What's your GPU? I had a similar problem because I wasn't using the proprietary nvidia driver – agoe1179 Feb 13 at 4:54
  • 1
    Hello. Can you try installing your graphics drivers from Appcenter, or with the command sudo ubuntu-drivers autoinstall ? I think your steam installation was alright, must be a misconfiguration with the drivers. – Maccer Feb 15 at 14:55
0

I'm not sure what could cause this, but as a workaround you can try another installing method for Steam, which there are several of.

  • There are two different Steam applications listed on the AppCentre. From what I've gathered the one called Steam is the regular installer while the one called Steam installer has some slight modifications for Ubuntu (which elementary OS is based on). I have used the latter one.
  • Valve-provided Steam DEB installer. You can find it here and use Eddy to install it.
  • Flatpak at https://flathub.org/apps/details/com.valvesoftware.Steam

You can also search and ask for help in Valve's Steam for Linux Client GitHub page: https://github.com/ValveSoftware/steam-for-linux/issues

| improve this answer | |
  • Thanks for the help - I tried all 4 methods you gave me, but still not working. I'll go check out the GitHub page now. Thanks again. – Gareth Stewart Feb 12 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.