I have a late 2011 MacBook Pro which has been running Snow Leopard without a hitch for several years.

I have tried previously to boot from USB on this MacBook, with no success, and I had the impression that these older Macs won't boot from USB.

That being the case, I decided to try installing elementaryos-5.1-stable.20200204.iso by burning it to a DVD.

Upon booting (holding down option key), the install disk came up (as "windows") and I selected it, it ran and said (something like) "running elementary OS" for a few seconds, and appeared to be booting up ok. I went to make coffee and came back about 10 minutes later, the screen was black and nothing seemed to be going on. I waited around 40 minutes, no change.

I powered off and restarted the machine, to find that, while the LED on the front illuminates and there is some whirring from the HDD, there is no Apple "DAH" POST sound and the screen is black and inert.

I've tried all the various resetting key combinations, to no avail, the screen is blank. Shining a bright light through the apple logo, there is no prompt or login icon visible.

Does anyone have a clue for me? I've looked at the thread here and, while it sounds superficially similar, the experiences of other participants seem to include getting to the Mac boot screen, whereas I am not getting anything up on screen at all.

TIA, Steve.

1 Answer 1


Probably need to use the usb. I have read that the graphics card on this is not working and needs to be disabled in Grub and then permanently in the grub config.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.