1

After installing Elementary OS, there was no wifi adapter. I followed these instructions and it worked, however, my wifi was extremely slow compared to other devices using the same network.

The fix for this problem was:

 sudo modprobe -r rtl8723de && sleep 5 && sudo modprobe rtl8723de ant_sel=2

After running that command, my wifi becomes normal again, however, the fix is not permanent. Every time I boot up the PC, I need to run that command to not have slow wifi. I would like to make this solution permanent.

  • Try echo "options rtl8723de ant_sel=2" | sudo tee /etc/modprobe.d/rtl-ant-sel.conf – Jeremy31 Feb 23 at 13:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.