After installing grass gis in elementary OS 5.1 the item in the application menu does not work. The application can be started from the terminal but its appearance is anomalous with an annoying duplicate transparent window that should not be present (The application starts correctly in Ubuntu 18.04 Gnome and Linux Mint 13.3 Cinnamon).
This is the .desktop file present in / usr / share / applications:

[Desktop Entry]
GenericName=Geographic Information System
GenericName[ar]=نظام المعلومات الجغرافي
GenericName[az]=Coğrafi informasiya sistemi
GenericName[bg]=Географска информационна система
GenericName[bs]=Geografski informacioni sistem
GenericName[ca]=Sistema d'informació geogràfica
GenericName[cs]=Geografický Informační Systém
GenericName[de]=Geographisches Informationssystem
GenericName[el]=Σύστημα Γεωγραφικών Πληροφοριών
GenericName[es]=Sistema de Información Geográfica
GenericName[eu]=Geografia-informazioko sistemen
GenericName[fa]=سامانه اطلاعات مکانی
GenericName[fi]=Maantieteellinen Tietojärjestelmä
GenericName[fr]=Système d'Information Géographique
GenericName[gl]=Sistema de información xeográfica
GenericName[he]=מערכת מידע גאוגרפית
GenericName[hr]=Geografski informacijski sustav
GenericName[hu]=Földrajzi információs rendszer
GenericName[hy]=Աշխարհագրական տեղեկատվական համակարգ
GenericName[id]=Sistem informasi geografis
GenericName[is]=Landfræðilegt upplýsingakerfi
GenericName[it]=Sistema Informativo Geografico
GenericName[ka]=გეოინფორმაციული სისტემა
GenericName[lt]=Geografinė informacinė sistema
GenericName[lv]=Ģeogrāfiskā informācijas sistēma
GenericName[mk]=Географски информационен систем
GenericName[nl]=Geografisch informatiesysteem
GenericName[nn]=Geografiske informasjonssystem
GenericName[no]=Geografiske informasjonssystemer
GenericName[pl]=System Informacji Geograficznej
GenericName[pt]=Sistema de Informação Geográfica
GenericName[ro]=Sistem Informatic Geografic
GenericName[ru]=Геоинформационная система
GenericName[sh]=Geografski informacijski sistem
GenericName[sk]=Geografický informačný systém
GenericName[sl]=Geografski informacijski sistem
GenericName[sr]=Географски информациони систем
GenericName[sv]=Geografiskt Informationssystem
GenericName[tr]=Coğrafi bilgi sistemi
GenericName[uk]=Геоінформаційна система
GenericName[uz]=Geografik axborot tizimi
Keywords=gis;spatial;geospatial;database;remote sensing;hydrology;vector;raster;visualization;maps;wms;wfs;ogc;osgeo;

but I was unable to find anomalies or errors.

enter image description here

These are the files in / usr / bin involved in starting the application:

enter image description here

2 Answers 2


Try this: From a terminal 'GTK_CSD=0 grass74' when launching the app. Please do it and report back if it worked.



  • Thanks, it works perfectly by launching it from the terminal! Now it remains to be understood why starting from the application menu does not work. Starting the program In Ubuntu or Mint from dock or the application menu, first open the terminal and then the graphical automatically . In elementary OS the terminal does not start and therefore neither the graphical interface, any idea about it?
    – Andrew-63
    Feb 8, 2020 at 9:53
  • 1
    There's a bit of a reading you can do here: github.com/elementary/gala/issues/244 - TL;DR, a bug ;) You can edit the ".desktop" file (Shortcut) and add that parameter under the "exec" that way this variable is passed at the moment of double clicking the icon.
    – Mudito
    Feb 10, 2020 at 1:31
  • Thanks again for the tips, but before setting the variable in the .desktop file to avoid the graphic problem (and GTK_CSD=0 solve this part of the problem) I should solve the problem that the application doesn't start using the application menu but perhaps I had not clearly exposed the problem (or split the problem in two questions): from the terminal the application starts but from applications menu it doesn't start at all. Could it be because of the io.elementary.terminal emulator?
    – Andrew-63
    Feb 10, 2020 at 10:25
  • Try removing the "TryExec=/usr/bin/grass74" line from the desktop file.
    – Mudito
    Feb 10, 2020 at 14:27
  • Unfortunately it doesn't work
    – Andrew-63
    Feb 10, 2020 at 17:12

As a workaround you can create a bash script to run the app. Basically in the EXEC= field you would use your bash script path (i.e.: /home/user/script.sh).

Then your .sh script should just be used to launch the app:

GTK_CSD=0 grass74

Save it, 'chmod +x script.sh' and that should work –

  • I created the grass74.sh file; made the file executable; checked in the terminal with ./grass74.sh ok works. Changed the .desktop file with Exec=/home/andrea/Applicazioni/grass74.sh but unfortunately doesn't works: neither the terminal opens nor the application starts
    – Andrew-63
    Feb 14, 2020 at 16:26
  • Add (if you havent already) the following line to your .desktop file : "Terminal=true"
    – Mudito
    Feb 14, 2020 at 17:03
  • The existing .desktop file already has the terminal = option set to true. I also tried to create a new launcher with the AppEditor utility (terminal = true) but unfortunately it doesn't work either.
    – Andrew-63
    Feb 15, 2020 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.