I'm a Linux newbie. I have an Asus UM433DA-NH74 Raven Ridge Zenbook. I'm using 5.1 Hera Elementary OS with an AMD R7 3700u Vega 10 processor with 16GB of DDR4 RAM and a partitioned, dual-boot 1TB PCIEx4 SSD.

I did a Elementary OS "reset" and managed to re-obtain my Wifi, but my sound-system is still broken. I do not want to be scared of the system updates breaking my OS every time I update the system. Is there anything I can do? Any terminal commands I can type to get you guys some helpful information?

Edit: It'sFoss had a page on Ubuntu Sound Fixes. I tried all of them and nothing worked. The audio starts up for about a second and then cuts out like a radio-edit sort of thing.


  • Can you do (from a terminal) a 'uname -r' to obtain and show the kernel version that you're currently running? Also, When GRUB boots, can you start selecting "advanced options" and boot with other Kernel versions to try them out? Maybe the newest kernel is introducing some conflicts on your setup. thanks -Aldo – Mudito Jan 27 at 2:03
  • I'll give it a shot in the morning. Thank you Aldo. – Wist Jan 27 at 5:54

After the Elementary System reset the latest batch of system updates were fine. I suspect something to do with the kernel as Raven Ridge (AMD Zen+) processors tend to have kernel issues. I'll be wary of the advanced options to try different kernels if issues persist in the future. Thank you!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.