2

I run rEFInd on my laptop with Windows 10 and elementary OS. If I do not configure manual stanzas in rEFInd, it picks up the latest kernel version for elementary and displays: Windows 10, efi-grub and elementary OS, in that order. I want to change this order and display Windows 10, elementary OS and efi-grub. The reason I want to leave the grub entry is because it has the recovery option.

Currently, I achieve this using manual stanzas. But the problem in this case is that the code for elementary OS has the kernel number. Because of this, whenever I upgrade the kernel, rEFInd still runs the old kernel until I change it manually.

Any ideas for fixes? Or perhaps there is a .efi file for elementary OS that is compiled whenever a new kernel version is installed?

1
  • And as you would have it. There is another kernel upgrade on synaptic XD – smalltimer Sep 28 '15 at 20:18
1

My refind config file is this:

resolution 1366 768
use_graphics_for linux,grub,windows
dont_scan_dirs /EFI/ubuntu,boot,/EFI/freebsd
default_selection "Elementary OS"
dont_scan_files /EFI/Boot/BOOTX64.EFI

menuentry "Elementary OS" {
icon /EFI/refind/icons-backup/elementary.png
loader /EFI/ubuntu/grubx64.efi
options "acpi_backlight=vendor resume=UUID=82a50ea8-2f1e-4307-b823-7cb3b03c74a1"
}

menuentry "FreeBSD" {
    icon /EFI/refind/icons/os_freebsd.png
    loader /EFI/freebsd/boot1.efi
}

And grub config is

#The important option is GRUB_DEFAULT set to saved for last used
#set to 0 for first entry/latest kernel
GRUB_DEFAULT=saved
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash iommu=soft"
GRUB_CMDLINE_LINUX="quiet splash iommu=soft usbcore.autosuspend=-1"
4
  • I've got a similar setup, but I am assuming the /EFI/ubuntu/grubx64.efi that you load for elementary os takes you to the grub menu. I am talking about a direct boot into elementary splashscreen with "loader /boot/vmlinuz-3.16.0-53-generic.efi.signed" and an initrd. Any ideas? – smalltimer Nov 30 '15 at 11:03
  • I don't have the grubx64.efi file. How can I get it. I am using the EFI stub bootloader – Suici Doga Mar 29 '16 at 3:25
  • I installed GRUB and now works – Suici Doga Apr 7 '16 at 12:57
  • I added the rEFInd ext4 driver and removed GRUB. Better and faster – Suici Doga May 6 '16 at 5:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.