0

today I installed elementary OS (Hera) on my physical hard drive after weeks of tinkering around in a virtual machine:)

Unfortunately I ran into a problem after setting up everything:

Every time I click on the volume button in the top right corner the system freezes. I can see and move the mouse but I can't click on anything. Luckily it is possible to "win + T" or "ctrl + alt + F1" into a terminal and killing the "wingpanel" process (googled it) solves the issue.

There is no problem with anything else and I usually change the volume via a knob on my keyboard but I wonder if there is a patch around.

I googled at least an hour and didn't find this exact scenario. I would provide a report if neccessary but I have no idea how^^. I could't find any log file either.

(Sorry for the double post)

best regards

edit:

I found out that "killall spotify" (its a snap package) solved the problem. Just to reproduce I started spotify again but clicking the volume button didnt freeze the system again. Maybe the system as just overloaded with all those snaps because I installed and ran everything without really "closing" the programs.

Sorry that long post :)

0

Since the problem happens when Spotify(snap) is running, try installing Spotify with the following instructions:

Uninstall Spotify from snap with sudo snap remove spotify or in the snap store.

Install curl: sudo apt install curl

Run: curl -sS https://download.spotify.com/debian/pubkey.gpg | sudo apt-key add -

Then run: echo "deb http://repository.spotify.com stable non-free" | sudo tee /etc/apt/sources.list.d/spotify.list

Finally: sudo apt-get update && sudo apt-get install spotify-client

Reboot and try using Spotify again.

This info was taken from the official Spotify Webpage for Linux

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.