1

The title is very straight forward, I started using eOS since last 2 years as far as I remember, started with linux with this distro also so, I´m a little noob.

I frequently use eOS and windows, so I decided to make my laptop dual-boot to use the Adobe program library, game a little bit and for some educational purposes and I use linux when I need to program or just use the laptop for my daily basis.

I new that eOS got an update few weeks ago but I didn´t use eOS those weeks, until today that I wanted to update but I can´t. tried via GUI (System Settings by checking updates) and via terminal with

sudo apt-get update && sudo apt-get upgrade

But none of those worked for me, when entering the App Center it shows me a Fetch Update error and cant update anything, also when using the update command and the upgrade throws some errors, upgrade shows this text:

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
  • I recommend you to try sudo apt update only first and edit your question with the errors you recieve using this command. If the error is the one you already post in your question - did you try to run with --fix-missing? – Bo rislav Jan 25 at 17:35
  • also you might want to try ... "sudo apt --fix-missing update" – George Barbaz Jan 25 at 22:34
  • @Borislav when I put sudo apt update I get this error: Reading package lists... Error! E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable) E: Unable to lock directory /var/lib/apt/lists/ E: Problem renaming the file /var/cache/apt/pkgcache.bin.QAgp2e to /var/cache/apt/pkgcache.bin - rename (2: No such file or directory) W: You may want to run apt-get update to correct these problems E: The package cache file is corrupted – Isaac Serrano Jan 26 at 18:37
  • @GeorgeBarbaz Here is the log – Isaac Serrano Jan 26 at 18:40
  • okay the one thing I am noticing in the log are the errors for opera and google ... suggestion ... find where those are and comment them out ... then try the update/fix again ... ... sorry just noticed the answers below ... I guess I am just re-iterating what they are saying ... remove the sources that are causing the PGP errors ... then try again – George Barbaz Jan 28 at 21:01
1

I see a few errors. The important one is that it looks like you have some broken package lists files. In order to fix it, an option is to clear all files and recreate them again. To remove them you can execute into terminal

sudo rm -rf /var/lib/apt/lists/*

it will remove all package files and directories, it is important to have an asterick (*) at the end of the line in order to keep the directory.

After doing this, use sudo apt update in order to get the files again. Post a comment if you have any errors after doing this.

There are some other errors - a few of your repositories in your lists are not signed (log file from the other comment), you better remove them from your lists, because they do not work like this and spotify and opera never will be updated.

| improve this answer | |
0

When I have seen this type of error ... there was a another apt update process running ... do a ps -ef |grep apt and see if you can find and kill that process and them run the fix

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.