1

For standard DVD playback, I have installed

Ubuntu restricted extras 

For encrypted DVD playback, I have run

sudo /usr/share/doc/libdvdread4/install-css.sh

I have also rebooted my laptop.

When I click on Files, the encrypted DVD is listed. When I click on the disk, I'm able to see the VIDEO_TS folder and the contents therein. If I click on any of the VOB files, Videos opens with an error dialog that reads Oops! Audience can't play this file! No URI set.

If I open Videos, I do see the option that reads Play from Disc, but when I click it, it loads the previous video I was watching.

Any idea how to get DVD playback working?

  • i too am facing this problem on a fresh install of freya 0.3.1 i installed vlc media player and it still would not play i tried 4 different dvds too. and i installed libdvdcss2 – Felipe Simmons Oct 25 '15 at 10:37
2

From the Description for package ubuntu-restricted-extras:

Please note that this does not install libdvdcss2, and will not let you play encrypted DVDs. For more information, see https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs

There's some troubleshooting as well as how to set region code for the drive at that link.

Check output for:

apt-cache policy libdvdread4 libdvdnav4 ubuntu-restricted-extras libdvdcss2 libavcodec-extra-54

It should show 3 asterisks next to the installed version of each, like this:

ubuntu-restricted-extras: Installed: 60.1 Candidate: 60.1 Version table: *** 60.1 0 500 http://us.archive.ubuntu.com/ubuntu/ trusty-updates/multiverse amd64 Packages 100 /var/lib/dpkg/status 60 0 500 http://us.archive.ubuntu.com/ubuntu/ trusty/multiverse amd64 Packages

If it isn't installed, you'll get (none) for that package. To my understanding, all of those should be installed as they're dependent packages, save for the libdvdcss2 package which is installed with the script install-css.sh. But this will verify that fact.

Hope that helps. :)

`

  • Hi hahacompliance. I ran the apt-cache command and all the components you listed are installed. The full output is here: paste2.org/cEPFGfyA. Unfortunately, the problem persists. – wickyd Sep 29 '15 at 1:13
  • I'll try this out on a Freya system here and report back as soon as I can. I simply have yet to bother with setting up DVD playback in Freya. Have you tried VLC or SMPlayer, do they by chance playback? EDIT: Any luck with trying to set the region code? Any success with the other troubleshooting steps in the 1st link in my post? Also, to clarify, when you say "It loads the previous video I was watching", do you mean DVD VOB file, or some local other, non-DVD type video file? – hahacompliance Sep 29 '15 at 6:27
  • VLC did not help unfortunately. I set the region, now Videos pops up the "Oops! Audience can't play this file! No URI set" error immediately, which is an improvement. "sudo chmod 660 /dev/sr0" done, no change. "sudo chgrp cdrom /dev/sr0" done, no change. "less /proc/sys/dev/cdrom/info" confirms that sr0 is the correct device. Videos would automatically jump to the last non-DVD type video file I was previously watching, but it no longer does that after setting the region code. Still no DVD playback unfortunately. – wickyd Sep 29 '15 at 8:21
  • If VLC doesn't play DVD's, then your ubuntu-restricted-extras package didn't install properly, ie. missing dependencies. Other things, does your DVD drive work? Have you tried other DVDs? I just set this up on a fresh Freya v0.3.1 updated from v0.3 ISO, still running kernel v3.16. I installed the restricted-extras package, which installed the restricted-addons package and all listed dependencies/recommends which I verified and still no go in "Videos" Audience app. VLC & SMPlayer playback just fine. I filed a bug report, more details here: bugs.launchpad.net/audience/+bug/1502733 – hahacompliance Oct 5 '15 at 1:28
  • Here are some notes I made, maybe this will help you check all the installed packages and such. paste2.org/CgbdvM07 – hahacompliance Oct 5 '15 at 1:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.