1

How do I get the control button to work in the terminal? control-shift-c does not copy, control-q does not kill processes, and without use of the control key I am finding it impossible to use nano or vim. I am used to coding with the MacOS terminal command line. Please help!

2

I figured it out! I think the key mappings were thinking that my keyboard was a full-size iMac keyboard instead of the Macbook Pro keyboard. I followed the first part of this tutorial and it fixed the problem! https://medium.com/@petrstepanov/a-macos-like-keyboard-remap-on-ubuntu-linux-cae1d108a97

I switched the xkb mapping for command and control. This worked like a charm and I am so relieved. The actual physical control key on my keyboard still isn't working, so I think that particular piece of hardware might be broken, but now that the left command key has been mapped to control's functionality, I can do everything I need to within the terminal.

| improve this answer | |
  • 1
    If this resolve your problem you should mark your question as answered, so more people can see it and use it. – ubgus Jan 22 at 8:58
0

Right click on the terminal window, you should see the shortcut and commands. Can you re-try after validating that you're using the correct keys?

Also, can you screenshot what you see in that window when you right-click? thanks!

| improve this answer | |
  • Thanks for asking! There are no shortcut and command options when I right click within the terminal, though... :/ – Katelyn C. Jan 22 at 4:54
0

There's a Preferences pull-down menu in the upper-right corner (shaped like a gear), which has an entry "Natural Copy/Paste". Switching this off will switch copy/paste from Ctrl-C to Ctrl-Shift-C etc.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.