As you can see from the picture, I get this error, I've tried changing boot type to either ufi or legacy and get the same error. I have a desktop with Windows 10 on I can boot from the boot USB no problem on that don't get any errors?

  • 1
    How much RAM does that laptop has? Not sure if it's related or not but that info might help as it fails mounting SquashFS – Mudito Jan 21 '20 at 5:57

Even if it works on the desktop, I would check the MD5 checksum from the elementary.io site after downloading the ISO and then re-create the USB (Balena Etcher should do the trick if you're creating from Windows or Linux).

  • I'm not coming from windows, I have deepin on my laptop but windows on my desktop. It boots fine from my desktop but not the laptop, the md5 is as it should be and I've used several different methods including deepin boot maker, dd, rufus, unetbootin. All work on desktop none on laptop. – danny hewitt Jan 21 '20 at 7:51
  • Does the laptop has a CDROM drive? Also, can you make sure on the laptop BIOS that boot order is 1st) USB, 2nd) HDD, 3rd) CDROM (If it has one, make sure it's last). – Mudito Jan 21 '20 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.