0

When I connect any camera to my Elementary OS (I've tried two from different vendors), the camera mounts as read-only (can't delete files, create folders, rename, ...) and none of the images has a preview.

While I can browse the images in Photos, they take ages to load – it's definitely slower than copying them to my computer.

The address in Files is gphoto2://[usb:001,026], dragging any file to the terminal shows /run/user/1000/gvfs/gphoto2:host=%5Busb%3A001%2C026%5D/. That means my camera connects in PTP mode (source).

.

screenshot of Files showing a readonly picture without preview

.

Is there any way to fix this and make my camera automatically mount as read-write and with image previews?


EDIT: I tried using gphoto2 terminal utility to access the camera. I could list the file structure with:

gphoto2 --auto-detect --list-files

I could even take a photo with --capture-image. But trying to create a folder resulted in a segmentation fault:

➜  ~ gphoto2 --auto-detect --mkdir=/store_001 
Model                          Port                                            
----------------------------------------------------------
Nikon DSC D3100 (PTP mode)     usb:001,027     
[1]    13953 segmentation fault  gphoto2 --auto-detect --mkdir=/store_001

I haven't tried setting up USB permissions, as the manual says, yet. The steps are quite complicated and I didn't know which ones apply to me when I'm using gphoto2 as a terminal command.


EDIT 2: I tried on two computers (both on elementary 5.1) with tree devices each. Nikon D3100 and Xiaomi Redmi Note 3 had the same problems on both computers – the device was readonly and had no thumbnails. With Xiaomi Redmi Note 7 in PTP mode, everything works all right – I could delete/create files and folders, I could turn on thumbnails.

  • It is not clear which protocol the device is using to connect. If it is MTP for example there are known problems. It might be worth checking the settings on the camera to see whether there are any other modes for connecting. – Jeremy Wootten Jan 20 at 10:53
  • Yes, it is probably MTP. Sadly there are no other modes on the camera. I found this bug upstream, it says that MTP devices are mounted read-only by default. But is there a way to make them mount in read-write mode manually? – m93a Jan 20 at 14:31
  • Oh, so it's actually not MTP, it's PTP. I edited the question to make it obvious. – m93a Jan 20 at 14:43
  • 1
    I have an Android phone that I can connect using PTP and I can create/copy files on that as well as thumbnailing the photos on there using Files. An old MTP music player I have only allows me to create new folders but not files (??) – Jeremy Wootten Jan 21 at 17:26
  • You could try installing gphoto2 (using synaptic or the commandline as it is not in the AppCenter) and use that to mount the camera. – Jeremy Wootten Jan 21 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.