corrupted panel and dock popover

I believe its become like this after an update that i did on 16 jan. Didn't install any application or something that can cause for this. Anyone has the same problem? I restarted or shutdown few times. Didn't change anything. If i click any of panel icons its corrects it self. You'll see below. Any thoughts?

enter image description here

2 Answers 2


There seems to be a problem with the last update of xserver-xorg-core-hwe-18.04 or xserver-xorg-legacy-hwe-18.04 with Radeon graphics cards, which break the rendering of boxes and tooltips.

They just uploaded a fix in launchpad. Just update the packages to their newer versions

xserver-xorg-video-amdgpu-hwe-18.04:amd64 from 19.0.1-1~18.04.1 to 
xserver-xorg-video-ati-hwe-18.04:amd64 from 1:19.0.1-0ubuntu1~18.04.1 to 
xserver-xorg-video-radeon-hwe-18.04:amd64 from 1:19.0.1-0ubuntu1~18.04.1 to 

Or download the .deb files and install them with Eddy or dpkg

Take note, this are proposed packages and are still in testing. It worked for me, but it might not work for everyone.

More about the bug here.

  • I updated with eddy and worked out. Thank you. Commented Jan 23, 2020 at 14:18

UPDATE I might have an actual answer / workaround: booting with kernel 5.0 (instead of 5.3) makes these issues disappear. During boot, select "Advanced options for elementary", then "elementary, with Linux 5.0.0-37-generic" (instead of the default 5.3.0-26-generic option). With this older kernel, the screen update issues do not occur for me.

Original post:

I'm seeing similar graphics errors across the system -- all sorts of display elements do not update until I mouse over them. Affected programs include Emacs, Firefox and the desktop background picture right after login.

(I am seeing this effect on other distributions as well, and have been using Elementary OS partly because it did not have that problem.)

I am using an hp spectre folio (Intel i5-8200Y with onboard graphics).

(I would post this as a comment but do not have enough reputation to do so; sorry)

  • If you found a solution, it is better to be an answer instead of a comment - just like you did. Accept your answer now in order to be visible for everyone that the problem is resolved and this way you will gain some reputation.
    – Bo rislav
    Commented Jan 17, 2020 at 16:05
  • Thanks for your encouraging words! But I am not sure that my problem is the same as KaanErdogan's who asked the question, so I'll leave it up to him to accept the answer.
    – Rudi
    Commented Jan 18, 2020 at 9:01
  • Oops, my mistake, I missed to notice, that it is a different person. No matter that, it is correct to post this as an answer, it is not correct to post as an answer something like 'me too' or 'I have the same problem!'
    – Bo rislav
    Commented Jan 18, 2020 at 10:08
  • Nope didn't worked out. Btw i remembered this is probably about the folder i took from a friend. That folder and folder/files under that has wrong names like utf problems. There are some marking in names. I'll delete that folder and reboot. Maybe something will change after that. Can't delete right now because i need it but soon as i delete that folder i'll write changes here. Commented Jan 19, 2020 at 1:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.