4

I have a problem with elementary and I am wondering if anyone has experienced and solved the following issue. My screen seems to freeze after doing some tasks, sometimes the mouse is frozen too and other times it is not and the audio in the background is still running. AS far as I can remember the freezing SOMETIMES happens when I do one of the following:

  1. Transferring large files across storage devices.
  2. Use my computer after it has been sleeping.
  3. Deleting a bunch of files at once, say, 50 or more.
  4. Leave my computer for a little while then come back and start using it.
  5. (New) Changing system font.

I think my system is full up to date and I don't ever have many programs running at once on it. Thank you in advance for any help you can offer :)

4
  • 1
    I have the same exactly the same problem, for now i dont know what to do. I thinkin yo reinstall elementary but i dont want to take that way becouse i means to lost a lot of work. I hope someone found the solution. At today i update de system so lets see if it solve the problem Jan 24 '20 at 13:25
  • I would suggest adding all the info you can about your hardware
    – corlaez
    Jan 30 '20 at 15:37
  • I'm also facing this issue. Are the CTRL + ALT + F2 working for you? (in order to get a terminal)
    – ZedTuX
    Mar 28 '20 at 5:03
  • It is a problem with the kernel and firmware. Can any of you who have this issue just type kn terminal lscpi and put results into pastebin and provide link to a paste, please?
    – Sysadmin
    Jun 10 '20 at 8:45
1

The first step in resolving these issues is to see if you can establish whether your system is CPU bound, I/O bound, or memory bound. This is just a fancy way of saying you have a bottleneck at the CPU, disk/network, or memory.

Install Gnome System Monitor from the AppCenter and when you start to notice the system is slowing down or freezing open it up and look at the Resources tab:

enter image description here

The top section represents the CPU load and if one or more of them are at or near 100% you probably have a CPU bottleneck. If this is the case look at the Processes tab, sort the table by the CPU column by clicking on it:

enter image description here

The application(s) at the top of the table will most likely be the culprit.

The second section on the Resources tab is your memory, if the "Memory" line is maxed out and the "Swap" line is up off the floor then you probably have memory issues. You can go back to the Processes tab and sort the table by Memory:

enter image description here

Once again the apps at the top are typically the offenders.

I/O bottlenecks typically are the result of downloading large files or web pages and result in browser tabs spinning and applications that use the internet stalling out but the rest of the UI should be reasonably responsive. This doesn't seem like the issue you are having so I won't go into a lot of detail though if you notice the lines in the last section of the Resources tab (Network History) are at the ceiling consistently when you experience a freeze you may have an I/O issue.

0

It can be a firmware issue. I have had similar issue. I have i915 socket for my GPU. All I did was to download firmware for this socket and compile with the kernel above 5.5 where the issue has been solved. Command lscpi can show the hardware. When you want to perform sudo update-initramfs for current kernel it shows what firmware is missing. Both methods are good to check do you need a firmware. If you need a tutorial check here: Unbelievably slow?.

1
  • Edited an answer above and added a hyperlink, where I provided an example of the solution.
    – Sysadmin
    Jun 10 '20 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.