0

I had a setup with 4 fixed workspaces and it was working fine up until now but the setting is not correct anymore. It seems I have a dynamic workspace again with 1 workspace.

The following commands do not change anything.

gsettings set org.pantheon.desktop.gala.behavior dynamic-workspaces false

gsettings set org.gnome.desktop.wm.preferences num-workspaces 4

Is there another way of fixing the number of workspace to 4?

2
  • The same issue. Gala ignores dconf settings. gsettings set org.pantheon.desktop.gala.behavior move-maximized-workspace false - doesn't work as well. Pantheon terminal - ignores dconf settings as well. waiting for an update. Jan 10 '20 at 12:57
  • Argh. Unfortunate.
    – Plussoyeur
    Jan 13 '20 at 9:39
1

There was an update which removed these gsettings keys and because of that they do not work anymore. I like this feature so I don't need it but I have found out that there is an option to stop going fullscreen on another space and make spaces fixed again by execution of

gsettings set org.gnome.mutter dynamic-workspaces false

I have test it a few times and it works for me, but I have enable it again, because I like the dynamic spaces option when you go fullscreen. In order to restore it, you can do it by exection of

gsettings set org.gnome.mutter dynamic-workspaces true
2
  • It does not work for me. I guess we are still waiting for some fix of this.
    – Plussoyeur
    Jan 13 '20 at 9:39
  • @Plussoyeur it works for me. at feb 27,2020. (remember do not run with 'sudo' )
    – user6308
    Feb 27 '20 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.