6

Since yesterday, when I try to update those two recommended items, the process fails and the updates are still showing. Sometimes, but not always, AppCenter crashes and closes. enter image description here All other updates are working fine, I am on Hera 5.1, Dell XPS 9550.

Anyone else and/or ideas?

Thank you.

EDIT

After having tried the latest answer with no luck, I tried this:

edo@XPS:~$ flatpak install org.gnome.platform
Looking for matches…
Found similar ref(s) for ‘org.gnome.platform’ in remote ‘flathub’ (user).
Use this remote? [Y/n]: Y
Similar refs found for ‘org.gnome.platform’ in remote ‘flathub’ (user):

   1) runtime/org.gnome.Platform.Compat.i386/x86_64/3.34
   2) runtime/org.gnome.Platform/x86_64/3.24
   3) runtime/org.gnome.Platform/x86_64/3.28
   4) runtime/org.gnome.Platform/x86_64/3.26
   5) runtime/org.gnome.Platform/x86_64/3.32
   6) runtime/org.gnome.Platform/x86_64/3.30
   7) runtime/org.gnome.Platform/x86_64/3.34

Which do you want to use (0 to abort)? [0-7]: 7
Skipping: org.gnome.Platform/x86_64/3.34 is already installed
edo@XPS:~$ flatpak install org.kde.platform
Looking for matches…
Found similar ref(s) for ‘org.kde.platform’ in remote ‘flathub’ (user).
Use this remote? [Y/n]: Y
Similar refs found for ‘org.kde.platform’ in remote ‘flathub’ (user):

   1) runtime/org.kde.PlatformTheme.QGnomePlatform/x86_64/5.9
   2) runtime/org.kde.Platform/x86_64/5.12
   3) runtime/org.kde.Platform/x86_64/5.13
   4) runtime/org.kde.Platform/x86_64/5.10
   5) runtime/org.kde.Platform/x86_64/5.11
   6) runtime/org.kde.PlatformTheme.QGnomePlatform/x86_64/5.10
   7) runtime/org.kde.PlatformTheme.QGnomePlatform/x86_64/5.13
   8) runtime/org.kde.PlatformTheme.QGnomePlatform/x86_64/5.11
   9) runtime/org.kde.PlatformTheme.QGnomePlatform/x86_64/5.12
  10) runtime/org.kde.Platform/x86_64/5.9

Which do you want to use (0 to abort)? [0-10]: 3
Skipping: org.kde.Platform/x86_64/5.13 is already installed

No luck either though.

At this point, if no one else if affected by this and there is no solution, I hope that the next time those packages will be updated, it will automatically work. Hopefully? Maybe? :)

7

I have the same situation since yesterday morning. So far I haven't any solution but I found this:

According to Hector R on this issue on GitLab

Step1

flatpak install org.freedesktop.Platform/x86_64/19.08

Step2

flatpak uninstall --unused

Step3

flatpak update

NOTE: in the latest step maybe the system update some packages and ask for download what you need and YES. After update the new packages run again flatpak update

Then reboot.

That's it

Hope helps.

And after this my AppCenter says "No components with updates" so looks like the problem is solved.

Regards, swnw

| improve this answer | |
  • Cheers, thank you for your help. Sadly, no luck but your reply helped me to try something else, see my above edit. – Travis Jan 12 at 9:46
  • @swnw Thanks. After I tried the edited solution mentioned by the OP (minus the kde part). In my case updating the gnome platform involved installing some other stuff as well, which were detected as missing during the installation process. Then after all that I tried your suggestion and it worked for me. +1 The Flatpak is no longer hanging in the AppCenter update queue. – Joy Jan 14 at 11:12
  • Same here! After the above comment comment I tried this again and it worked! Thanks a lot, I hated having those pending updates (OCD much? :D ) – Travis Jan 14 at 20:08
2

what I recommend you is to try to do this using command lines. Open your terminal application and execute

flatpak update

! without sudo, otherwise you will receive an error message. Another option that works for me in a bit complicated situations is sudo flatpak repair.

| improve this answer | |
  • Thank you, this is what happened with both, I still have the notification in the AppCenter: edo@XPS:~$ sudo flatpak repair Working on the system installation at /var/lib/flatpak Segmentation fault edo@XPS:~$ flatpak update Looking for updates… ID Branch Op Remote Download 1. [✗] org.freedesktop.Platform.openh264 19.08 i flathub 593,6 kB / 593,4 kB Warning: org.freedesktop.Platform.openh264 not installed Installation complete. – Travis Jan 10 at 15:53
  • I think this might relate to my problem, maybe? github.com/flatpak/flatpak/issues/2116 – Travis Jan 10 at 17:05
  • I have a lot of flatpak applications, but I don't have any problems with this. I received the same request for updates and I did the update from the appCenter with no issues. You are not the only one who has this problem, I do not have any KDE application from flatpak, this is the only difference - it may be the cost of the problem, but your response of the repair command is the same as the one the others having the same problem gives me. – Bo rislav Jan 10 at 19:06
  • I appreciate your effort. I really don't have much flatpaks, just Telegram and Dropbox. If enter the command flatpak list, some other stuff pops up but I think they have been installed in relation to Telegram and/or Dropbox. I tried to remove those two problematic packages and the Dropbox & Telegram apps, but reinstalling everything recreated the problem. Would love to use the official AppCenter versions of those two apps, but they are so outdated. – Travis Jan 10 at 20:52
1

@Travis So the conclusion is "No luck either though.". Actually it's my first time when I had update elementary os trouble. I think that elementary os creators should read elementaryos.stackexchange.com from time to time ;). Faltpak in their opinion is "the future for our AppCenter ecosystem".So I try to send them this link of troubles. Not so easy I'm trying to find, I thought. simple thing "the contact" :/. I have no Facebook and Twitter accounts - I deleted them, so I have no chance.

Regards, swnw.

| improve this answer | |
  • Yeah, I will try to submit this to the devs. – Travis Jan 14 at 8:44
1

Here's how I solved the flatpak update issue.

Update faltpak in Terminal.

flatpak update

One package org.freedesktop.Platform.GL.default found but got error when update.

List the installed package.

flatpak list

I found the same package is installed.

Uninstall that package.

flatpak uninstall [Application ID]

Update flatpak and it success.

flatpak update

Problem solved.

** Please confirm if it's a correct way. I'm only a normal user and not familiar which what I said above.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.